x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mapping "Swipe Up To Down" and "Swipe Left To Right" not working

Tried to use Swipes, in axis mapping and action mapping, swipes are not triggered. Also run on device, same problem - nothing happens on swipe.

Extended: Editor Version: Version 4.2.1-2101290+++depot+UE4-Releases+4.2 (Dowloaded from Launcher) issue occur 100%

Test on iPhone 5s, TestSwipeAction and TestSwipe axis not triggered to.

alt textalt text

Product Version: Not Selected
Tags:
ue4_2.png (59.8 kB)
ue4_1.png (77.8 kB)
more ▼

asked Jun 24 '14 at 06:54 AM in Bug Reports

avatar image

BorodMorod
137 14 19 23

avatar image Alexander Paschall ♦♦ EPIC Jun 24 '14 at 03:06 PM

Hey BorodMorod,

Thanks for your report. I assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide.

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

Thanks,

Alexander

avatar image BorodMorod Jun 24 '14 at 03:45 PM

Updated description, for more info.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Here is a quick solution alt text

swipesupportbig.jpg (104.9 kB)
more ▼

answered Jul 10 '14 at 08:58 AM

avatar image

Grigon
51 2 5 7

avatar image MaxSMoke777 Jun 20 '15 at 11:13 AM

Has the simple "InputTouch" been removed from the engine entirely?? I keep seeing this solution, and it seems like a good one, but the only inputs I have are directly attached to objects. I have InputTouchBegin and InputTouchEnd, and they are all tied to objects. They ignore if you end your touch in empty space. If I touch my object and slide off the object, it never registers as an InputTouchEnd, so the object can only be swiped once. It never counts as an end! Has anyone messed with this since UE4 4.8 came out? I think this swipe method is dead now.

avatar image TJ V ♦♦ STAFF Jun 22 '15 at 12:42 PM

Hi MaxSMoke777,

The InputTouch node is in 4.8 and it's available in the Player Controller blueprint. Let me know if this isn't what you find.

Cheers,

TJ

avatar image MaxSMoke777 Jul 09 '15 at 10:55 AM

Ok, I found the InputTouch, and it does seem to be useful, but it has a very tantalizing and completely undocumented pin called "Move". What is this pin and how do I use it? I'm trying to wrap my head around what it could be used for, since I'm starting to get a sense of how you guys like to handle things, but so far I haven't figured it out. I'm assuming it can be used directly for swipes and drags, right?

avatar image Rudy Q ♦♦ STAFF Jul 09 '15 at 05:15 PM

Hello MaxSMoke777,

The pin called Move fires off every tick that the finger is moving while touching the screen. This could be used to optimize dragging something across the screen. You could set up the move pin to update the nodes that set the position of the object that is being dragged. I hope that this information helps.

Make it a great day

avatar image quinx Mar 07 '16 at 06:37 AM

Thanks. This solution saved me a lot of time. I implemented in C++ but I followed your logic.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi BorodMorod,

Thank you for the feedback. I was able to reproduce this issue and submitted it to our developers for further investigation.

Your Blueprint setup is correct. I tested this against other inputs and controller analogs and they work fine. For some reason the values of the swipes always register as zero.

Thanks, TJ

more ▼

answered Jun 24 '14 at 06:16 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image BorodMorod Jul 10 '14 at 08:26 AM

On UE 4.3 Preview swipes still not working... T_T

avatar image C-Arch Oct 01 '14 at 06:46 AM

4.4.3 swipe is not working either.

avatar image TJ V ♦♦ STAFF Oct 01 '14 at 02:31 PM

Hi guys,

This is still TTP# 339641 in our tracking software. It has moved up in priority and our devs are looking into it.

Thanks, TJ

avatar image Ash1029 Dec 02 '14 at 04:30 PM

In UE 4.6 Preview it still isn't working. What a shame.

avatar image TJ V ♦♦ STAFF Dec 02 '14 at 06:52 PM

Hi everyone,

I updated JIRA UE-2979 in our new tracking software to let our developers know that multiple users are still being effected by this.

Cheers,

TJ

avatar image Anadin Dec 07 '14 at 03:17 AM

Just +1'ing me too :( using 4.6.0

avatar image Anadin Feb 23 '15 at 01:31 AM

Hi, just checking in again, still broken in 4.7p8

avatar image SONB Apr 06 '15 at 12:15 AM

So, from version 4.2 to 4.7.4 there was no progress?

avatar image TJ V ♦♦ STAFF Apr 06 '15 at 03:23 PM

Hi everyone,

Just an update on this report. This has not been implemented as of yet but the JIRA has moved up in priority and our developers are investigating.

Cheers,

TJ

avatar image TJ V ♦♦ STAFF May 13 '15 at 07:29 PM

Hi everyone,

The swipe bindings were accidentally exposed which is why they were not implemented. We have corrected the issue, which has removed them from the editor. Swipe bindings maybe added at a later date when our developers have time to implement them correctly.

Until then, there are several post for workarounds to the issue and even a plugin on the Forums.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question