x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

VR-Template - on level load, teleport function is broken

Hi! So, as per the title, I have a 3 seperate VR levels using the VR motion controller template(for Vive) which are essentially clones of one another but with slightly different content. The project is essentially a model viewer in an 'endless studio' type environment. I have set up a UMG menu widget and actor to select the desired level and load it. All functionality works fine (teleport, trigger animations, material change etc), however, as soon as i use the load level function in my menu and enter one of the other levels, the teleport function is broken. (see attached picture) I have noticed that I am spawning in the exact same position as when i triggered the 'load level' function rather that the spawn position of the VR pawn. Would this make a difference? I have not changed the navmesh or the floor mesh in any of the levels - they are all identical.alt text Scratching my head....does anyone have any ideas? Many thanks!

Product Version: UE 4.15
Tags:
more ▼

asked May 24 '17 at 09:31 AM in VR

avatar image

Deep-fried
11 3 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

check collisions, and make debug logic when teleport line hit something - set textrender with name of this object, and you can understand where is problem.

and second chek navigation , press P if green ok if no move nav mesh find what distrubbing this

more ▼

answered Jun 09 '17 at 07:41 PM

avatar image

6r0m
424 18 16 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Running into the same issue. Can run evach level independently and navigation works correctly. As soon as i try to combine maps and use level load navigation is broken. Seems to only effect vr navigation. Anyone find a soltuion?

more ▼

answered Aug 23 '17 at 02:57 PM

avatar image

BuddytheBurrito
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I got it to work after seeing this.....

https://forums.unrealengine.com/development-discussion/content-creation/48489-navmesh-of-sublevel?77202-Navmesh-of-SubLevel=

Basically the navmesh needs to be placed in the persistent level.... not in the loaded level. Hope this steers you in the right path.

more ▼

answered Aug 25 '17 at 03:49 PM

avatar image

SOLDIEROSCAR
3 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question