x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rigid body node fail

Hey, i just wanted to try 4.16 rigid body node in animBP but it constantly crashes my editor when I try to compile it. It works under errors for the default mannequin but just bluntly crashes on my own character. I use a completely custom skeleton with bone names that are different from the mannequin. I have setup a dedicated phat that has the same configuration as the mannequin. Here is a link to one of the crash log folderes: https://www.dropbox.com/sh/ytm9d7gyv00s411/AADZN20V8Hh_jnGKXBVOJL0Wa?dl=0

Here are some screenshots:

Default mannequin phat settings: https://dl.dropboxusercontent.com/u/25584030/ue4RigidBodyBugManneqPHAT.PNG

My phat settings: https://dl.dropboxusercontent.com/u/25584030/ue4RigidBodyBugStevePHAT.PNG

Mannequin animBP compile error and setup: https://dl.dropboxusercontent.com/u/25584030/ue4RigidBodyBugManneqError.PNG

My animBP setup.. https://dl.dropboxusercontent.com/u/25584030/ue4RigidBodyBugSteveSetup.PNG

If you need any more infos to help debug this, let me know. I want to know what the exact requirements for the PHAT settings are for the rigid body node to work, a documentation would be cool.

Thanks,

-S

Product Version: UE 4.16
Tags:
more ▼

asked May 24 '17 at 05:52 PM in Bug Reports

avatar image

Adeptus
31 1 7 9

avatar image ihavenick May 25 '17 at 08:16 PM

Enabling "Overlap Channel" node giving same error at me too. It seems its a engine side bug

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Adeptus,

The compile error explains that using world collision with component space simulation is not supported. You will need to disable the Component Space Simulation on the RigidBody node to get this working when the Overlap Channel is enabled.

If it still has issues after you clear up those warnings, please post a small test project with the asset you mentioned.

Cheers,

TJ

more ▼

answered May 26 '17 at 03:39 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image Adeptus May 26 '17 at 04:15 PM

Hey mate, thanks for that, but that isnt really what I was wanting to have looked at. Its the crash of the engine that happens when I compile it in my own character that uses a competely custom skeleton. I dont really care about the mannequin at all. Your answer is useful, but it doesnt solve my question as to why it crashes. Please have a look at the log I attached.

avatar image Adeptus May 28 '17 at 09:05 AM

I have also tried to disable component space simluation for my the thing in my project, but the engine still closes at compile. And in the log it doesnt say anything useful, therese are the last two lines:

[2017.05.24-17.46.17:665][ 76]BlueprintLog: New page: Compile maya_animBP [2017.05.24-17.46.18:832][ 76]LogWindows: Windows GetLastError: Der Vorgang wurde erfolgreich beendet. (0)

"Vorgang wurde erfolgreich beendet" means "the process has been successfully terminated" I have no idea why.

avatar image ihavenick May 28 '17 at 09:30 AM

Can you create another animblueprint and set a basic animation and try rigidnode to see if its crashing because rig or your complicated blueprint?

avatar image Adeptus May 28 '17 at 10:47 AM

Hmmm, thats interesting it worked on a fresh animBP. So at least it nothing to do with the way my physics asset is set up. It has something to do with my animBP, but that is very strange. Even if I detach all nodes except for locomotion machine and plug it into rigid body. It compiles for 2 seconds, then the engine closes, like its forcequitting from a long lag.

avatar image ihavenick May 28 '17 at 02:07 PM

i know it will be hard but, you can copy and paste step by step and find where is the bug is. And bytheway did you disabled animdynamics ?

avatar image Adeptus May 28 '17 at 02:09 PM

i tried with/without animdynamics disabled, the idea of a copy/paste is good. Ill try that later, thx.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question