x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG autowrap makes text flicker upon appearing

I have an UMG issue where the text flickers a millisecond upon appearing in the game. In that millisecond it seems that the text widget does auto wrapping to make the words fit in the text box. One can see that UMG re-arranges the words in textbox that millisecond. This holds even true if the text is a variable. My hierarchy is: Border - Canvas Panel - Text (see attachment) .

Is it possible to get rid of this small flicker? It is a small thing which adds up and diminishes the quality experience.

alt text

Product Version: UE 4.15
Tags:
more ▼

asked May 25 '17 at 01:28 PM in Using UE4

avatar image

JakobR
98 7 17 16

avatar image JakobR Jun 08 '17 at 11:08 AM

I've now inserted hard line breaks now with SHIFT + Enter . These should generate the fixed-width wrapping. Correct? I have tried the result on PC and a Nexus5 and I think the 1 frame auto-wrapping is gone now. Since the auto-wrapping is no longer called into action.

If I store my text in variables - I always need to calculate at what word it should go onto a new line. There must be a more convenient way to do this I hope? alt text Any help appreciated.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You can try fixed-width wrapping. Uncheck "Auto Wrap Text" and in the "Wrap Text At" field underneath it, enter the width that you want to wrap at (normally the length of the Text, or a few pixels less).

more ▼

answered Jun 19 '17 at 04:37 PM

avatar image

Archduke_
159 2 4 8

avatar image Onyxius Aug 08 '17 at 07:52 PM

I had to reply to say thank you Archduke_. That fixed it for me, it was driving me crazy.

avatar image JakobR Oct 06 '18 at 01:29 PM

Yes, indeed! Thanks @Archduke_

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Slate layout happens in a single-pass, and the comment for auto-wrapping states that it will have a 1-frame delay.

If you don't want that artefact then you'll have to used fixed-width wrapping (note that fixed-width wrapping may still be bound to something that changes its width, it just means that it's not automatically computed once the desired size is known).

more ▼

answered May 25 '17 at 01:36 PM

avatar image

Jamie Dale STAFF
7.5k 177 67 305

avatar image JakobR May 25 '17 at 02:10 PM

Thanks for the reply. How would I go about doing fixed-width wrapping to get rid of this artefact? Many thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question