x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.16 updated project crashes - Skel_ & LinkerPlaceholder.

I have a project in 4.15 that is stable but upgrading it to 4.16 it crashes so much. Play in editor, compile, migrate or deleting all causes crashes.

Errors I am receiving are:

Ensure condition failed: ChildActorTemplate == nullptr [File:D:\Build\++UE4+Release-4.16+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\ChildActorComponent.cpp] [Line: 95] LogOutputDevice:Error: Found unexpected ChildActorTemplate LinkerPlaceholderExportObject /Game/FirstPersonBP/Blueprints/ElectricitySystem/Parts/Part_Door.PLACEHOLDER-INST_of_PLACEHOLDER-CLASS__Mod_part_Base_Door_C_5 when ChildActorClass is null

Ensure condition failed: !bIsFilteredOut [File:D:\Build\++UE4+Release-4.16+Compile\Sync\Engine\Source\Editor\BlueprintGraph\Private\BlueprintActionFilter.cpp] [Line: 1689] [915]LogOutputDevice:Error: Invalid BlueprintActionDatabase entry (for SKEL_Part_Door_C). Was the database properly updated when this class was compiled?

And I am suspecting child actor components to be part of the issue.

Because of the report size and this website not lending well to formatted text, the report is inside a text file. I don't expect anyone to read or follow it - but it's there if it provides any useful information.

I also include two projects - one which is basically the project version and one that is heavily modified to remove errors as much as I could. Due to the size, and limited dropbox space I had to zip it. I hope that is okay.

There are also 4 log files.

Crash report: (use this) https://www.dropbox.com/s/7yikaztc9u02ya5/Crash%20report.txt?dl=0

7zip file: https://www.dropbox.com/s/odme15rqzytll38/New%20folder.7z?dl=0

I'd be happy to provide anything else that might be of use.

Product Version: UE 4.16
Tags:
more ▼

asked May 25 '17 at 06:49 PM in Bug Reports

avatar image

ste1nar
68 8 14 18

avatar image tslimone May 25 '17 at 07:23 PM

I'm having the same problem after upgrading to 4.16 as well... I thought the child actors just had broken references and remade them, but it did nothing. Weird thing is I get errors in just some child actor components, not all of them.


ATHelper: Packaging (Android (ETC2)): Cook: LogOutputDevice:Error: Ensure condition failed: ChildActorTemplate == nullptr [File:D:\Build\++UE4+Release-4.16+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\ChildActorComponent.cpp] [Line: 95]

UATHelper: Packaging (Android (ETC2)): Cook: LogOutputDevice:Error: Found unexpected ChildActorTemplate LinkerPlaceholderExportObject /.../BP_PlayerCharacter.PLACEHOLDER-INST_of_PLACEHOLDER-CLASS__BP_HUD_C_0 when ChildActorClass is null


edit: child actor components are definetely the cause of the issue, at least for me. Game packages fine without 3 specific components

avatar image VictorBurgos Oct 24 '17 at 05:00 PM

Bah, just ran into this issue as well in a 4.17 project. So, I'm going to try out some of these answers out and hope for the best ;) I thought Child Actors were finally stable... Joke's on me.

avatar image jonnyvegas Jul 26 '18 at 05:47 PM

In my case, I was doing some changes to variables on begin play for the child actors that I had in my blueprint. I tried the solutions here but didn't have any luck. I tried moving this over to the construction script to set the values I needed and it seemed to resolve the issue. I'm not sure if this will help anyone else but it worked for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

Ok, after a lost day of work, I managed to make a succesful build.

All I have really done was deleting and adding again all child actor components that were getting errors, trying to force an update on reference on them. I also tried adding a random variable to the classes of the actors themselves, also trying to force an update. I've done that on all the hierarchy of child actors (I had stuff like child actors inside the blueprint being used as CAC, for example)

Long story short... Try to update all components and classes associated, maybe it works.

edit: to fix one of the classes I actually had to restart the editor so the "Child Actor Template" was gone lol

more ▼

answered May 25 '17 at 11:15 PM

avatar image

tslimone
38 3 4

avatar image madmunkid Jun 11 '17 at 04:50 PM

Just wanted to note here I ran into the same problem upgrading a project to 4.16 from 4.15 specifically with child actors throwing this error: LogOutputDevice:Error: Ensure condition failed: ChildActorTemplate == nullptr [File:D:\Build\++UE4+Release-4.16+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\ChildActorComponent.cpp] [Line: 95]

My parent blueprint created 3 child actors at sockets on a skeletal mesh, and each of these actors (in their own blueprints) create a child actor.

The project would run but any attempt at packaging would fail

A couple of hours of deleting actors and recreating them, reloading etc etc and the error has gone, but I dont really understand why (On the plus side i probably managed to fix a minor bug in the process)

avatar image bggangel Jul 04 '17 at 05:21 PM

I am running into the same issue after upgrading from 4.15.3 to 4.16.2 . Is there someone who can shed a light on what might be the cause of this issue, as I have tried to delete and recreate actors now for the last 3 days with no success. Also: @madmunkid+tslimone: Can you describe what you did with deleting and recreating actors. Did you recreate these actors from scratch or replace them and what actors did you recreate? My message is : "Found unexpected ChildActorTemplate LinkerPlaceholderExportObject /Game/Shared/Blueprints/CharacterCards/base/BP_base_CharacterCard.PLACEHOLDER-INST_of_PLACEHOLDER-CLASS__BP_base_Buttons_C_1 when ChildActorClass is null" The BP_base_CharacterCard has 1 child actor "Button Group" which is an actor with 1 main button and 2 childactors (also buttons). And they work with an interface, so I have a lot of potential blue prints to rebuild. I have tried many so far but as soon as I implement the interface to the new blueprint, the error comes back. I have also added IsValid statements everywhere where I can think of. At one point I narrowed one of the causes down to this point. Picture 1 will not cause an error. Picture 2 will. alt text alt text

Does anyone have an idea? And lastly: Is it safe to continue developing? Is this an engine failure and is it safe to continue with this and wait for a fix? (The problem is in a low-level class)

[1]: /storage/temp/191594-pic1.png

pic2.png (38.1 kB)
pic1.png (35.1 kB)
avatar image bggangel Jul 04 '17 at 06:00 PM

some additional info: Not sure if this was always happening and I missed it, or if this is new, but now if I open the editor on a map where the offending bluepint is not on and open the blueprint the log actually shows the same error. This will at least speed up the detection of the problem (as I do not have to wait for the cooking) and tells me there is a problem with or around the initialization of the child actors. But still: does anybody have an idea?

avatar image bggangel Jul 05 '17 at 01:02 AM

ok, in case someone is interested: I was able to fix the problem by unchecking "Editable when Inherited" on the Buttons group (the class that was identified by the "PLACEHOLDER-INST_of_PLACEHOLDER-CLASS__BP_base_Buttons_C_1" part. Pretty sure it had to do with something in the initial loading and when setting it to "None Editable" this is not triggered. For now this works for me. Worth a try in case you run into this.

avatar image tslimone Jul 05 '17 at 08:26 PM

In the end what we have actually done was taking the child actor components off of the parent actors and creating/setting them on variables instead, on begin play.

avatar image bggangel Jul 05 '17 at 08:55 PM

yes, to me, that implies you had the same problem during the initial (first) initialization. You bypassed it by setting it later, I guess that works also, but I do think this is a bug somewhere. Hopefully one of our workarounds will help others.

avatar image Motanum Sep 26 '17 at 04:46 PM

I just ran into this problem when my project packaged fine just some weeks ago.

My question is, how do you manage movement when the parent actor gets moved, so that the child actor moves with the parent too?

I have tried so far to recreate the child template variable. To remove the editable inheritance on the child actor (BPButton_GameOptionsPageChange). What is weirder is that another actor called GameOptions2 has the same child bp class and that one doesn't return an error, But the actor GameOptions3 does create this error. I am just, so baffled by this.

avatar image Motanum Sep 26 '17 at 05:16 PM

Well, it seems like it was a matter of it being called before it being initialized or something? I set this up, and the error is not being thrown anymore when packaging.

alt text

avatar image VictorBurgos Oct 24 '17 at 08:35 PM

Thanks bggangel, with your solution I was able to get it to package.

avatar image VictorBurgos Oct 24 '17 at 08:15 PM

Sadly this did not work for me. Deleting, restarting Editor, reAdding Child Actors Components did nothing. Trying out a few other recommendations on there though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This error used to ruin me, but I just found a super simple way to fix it: Simply create a child class of the class that's causing the problem and replace the child actor component's class with your new childClass.

Example: Your BP_Hero has a child actor component of class type BP_Gun. This gun child actor component is throwing the error.

  1. Find your BP_Gun blueprint and create a child class. (Right click, create child class) Now you have BP_Gun_Child

  2. In BP_Hero, change the culprit child actor component's class from BP_Gun to BP_Gun_Child

  3. Package your project without errors. Celebrate

I run into this error more frequently than I'd like. This hack is easiest way to solve the problem.

more ▼

answered Dec 19 '17 at 04:06 AM

avatar image

lukefwilson
160 16 20 22

avatar image Isrraka Feb 15 '18 at 10:59 AM

Thank you!!

This hack work for me in 4.18.3. None of the others solutions in this thread let me package the game but this hack made the trick! Not only that!! Now the values in blueprint child actor variables don't reset at editor startup! Your comment should be marked as "the solution".

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The solution seems to be this from the comments above (at least for 4.18.3 where the issue still happens):

ok, in case someone is interested: I was able to fix the problem by unchecking "Editable when Inherited" on the Buttons group (the class that was identified by the "PLACEHOLDER-INST_of_PLACEHOLDER-CLASS__BP_base_Buttons_C_1" part. Pretty sure it had to do with something in the initial loading and when setting it to "None Editable" this is not triggered. For now this works for me. Worth a try in case you run into this.

More precisely, say you have a BP_Character and a BP_Weapon (actor and child actor). In the BP_Character, find and select the child actor component (which has a child actor of BP_Weapon) and in the Details panel, uncheck Editable When Inherited. Then, select its parent component, uncheck Editable When Inherited again, and keep going up the chain to get all ancestor components. After that, it "should" work.

I ask the OP to accept this answer (if it works for OP as well) to make it easier to find. I had to read through all this to get to the solution!

more ▼

answered Jan 24 '18 at 08:03 PM

avatar image

Todd.Vance
32 1 5

avatar image strangeman Feb 13 '18 at 01:22 PM

All of this solutions are not work for me. 4.17.2 or 4.18.3 - no progress. Moreover, things that worked in older version, does not in newer one. There were 3 complex objects with childs of 2 types. But one of objects (most simple of all !) works properly with all the children of type 1 and only one child of type 2. Deleting/adding, duplicating the "good" child, unchecking "Editable..." did not work. In 18.3 this object accepts two(?!) children of type 2 and (ta-da-a-am!) 0 children of type 1. Adding one more by any of ways crashes packaging. 0_o Give me some hope, please...

avatar image strangeman Feb 19 '18 at 05:54 AM

Ok, after all a have find out the way to workaround this problem. I add ChildActor Component and specify the ChildActor, set proper transform to component, then clear the ChildActor and set it in Construction script with all details. It's better than nothing.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So the Skel_ errors that me and tslimone got was associated with Child actor components but even though I fixed it so I got no more of those errors, my project still crashes.

So I have been trying to narrow down the issue. I have a "Default" project, which is the original project and have been deleting classes, functions and other data to remove things that does not affect these crashes, constantly cloning the project as I go. As I have deleted some things I have noticed that they fix the crash symptoms - but when redoing that action in the Default project, few have fixed the crashing and none to satisfaction since it involves deleting critical parts. I am now down to a project with 12 classes, most are empty of functions and other things. At this point, pretty much anything I do will fix the crashing in this reduced project, but not the default one.

An example of a 'fix' is that the third person character has a node "Spawn actor(Ball)". It's not connected. If it is in the blueprint, the project crashes. If it is deleted, the project stops crashing. But deleting it in the default project does not stop the crashing.

I have no idea what is going on, project was completely stable in 4.15

Again, I will share the Default project and the reduced project.

Report: https://www.dropbox.com/sh/fu8v2872nb5jrjz/AAAJCqlKgCClCAoBHbP5cnqAa?dl=0

BP Classes rundown: https://www.dropbox.com/s/1oqoafpkkq6s7ns/Setup.png?dl=0

Default Project: https://www.dropbox.com/sh/2ejlw0klw4gse1j/AACb18XjzNcmXfWaX7hu18mka?dl=0

Reduced Project: https://www.dropbox.com/sh/768d4nfax6gtscf/AAA3_kGyWKdPaSI-65yLqAuVa?dl=0

Please let me know if this is of any use at all.

more ▼

answered May 30 '17 at 11:41 PM

avatar image

ste1nar
68 8 14 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Interestingly enough, I had to combine two of these solutions. But honestly, the second one could have been what fixed it all.

My scenario: Inventory system. In Character I had 6 slots (child actor comps). One of those slots was a Backpack BP, inside that Backpack, I had two additional Child Actor Components attached.

Fixed by doing this:

  1. Deleting child actor component from character and readding them after saving and closing out of editor

  2. Unchecking "Editable When Inherited" from the details tab of the Child Actor Components alt text

I am 99% sure it was really the latter that got this to work. But I am not going to try to repro this.

POST EDIT - This ended up regressing somehow. I ended up just Spawning the Actor BPs and Attaching them to Components already placed on my character.

more ▼

answered Oct 24 '17 at 08:35 PM

avatar image

VictorBurgos
2.4k 61 27 113

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm getting this in 4.18 as well. It happened when I initially set the child actor class and then removed it, so I guess it still has that actor serialized but it shouldn't be there anymore.

more ▼

answered Nov 01 '17 at 11:02 PM

avatar image

duke22
190 11 16 31

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My current working theory is that this error can occur if there's a cyclic dependency in your project making the compile order unclear or unresolvable. If, for example, Class A casts a child component to Class B and sets a variable on it, while meanwhile Class B does some operation on an instance of Class A, you're going to run into problems because Class A can't be compiled until Class B has been compiled, but Class B can't be compiled until Class A is compiled.

My experience has been that these sorts of circular references can behave in strange ways, since what they do depends entirely on the order in which assets actually get compiled, which is why creating child objects of an offending class could conceivably correct the issue, since then the parent object could simply as a matter of luck be compiled in time to be used.

This is just a theory, but I recently resolved one of these issues by cleaning up my inheritance architecture so two objects no longer needed to know about each other to compile. Or I just got lucky.

Epic's own code concedes that there isn't a clear handle yet on what's causing this.

 if (ChildActorClass == nullptr)
 {
     // It is unknown how this state can come to be, so for now we'll simply correct the issue and record that it occurs and 
     // and if it is occurring frequently, then investigate how the state comes to pass
     if (!ensureAlwaysMsgf(ChildActorTemplate == nullptr, TEXT("Found unexpected ChildActorTemplate %s when ChildActorClass is null"), *ChildActorTemplate->GetFullName()))
     {
         ChildActorTemplate = nullptr;
     }
 }

more ▼

answered May 19 '18 at 03:58 AM

avatar image

KevODoom
176 5 8 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question