x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Widget Interaction Component broken in 4.16?

Just upgraded to 4.16 and the widget interaction component in my VR project is no longer functional. It doesn't even show up in PIE when 'show debug' box is ticked.

An error message says "Error The cursor class '/Engine/VREditor/UI/VRRadialCrosshair.VRRadialCrosshair_C' was not found, check your custom cursor settings.". Although I'm not sure this is the issue, since it can be solved by using a custom widget in the Default Software Cursor in Project Settings under User Interface. Once that is done, the error message disappears but the widget interaction component is still not working.

I'll stick with 4.15 for now, but I was looking forward to the new release so it would be great to get this fixed as soon as possible.

Product Version: UE 4.16
Tags:
more ▼

asked May 25 '17 at 08:10 PM in VR

avatar image

Fractal_C
16 1 2 5

avatar image AquilaEagle May 26 '17 at 05:18 AM

I'm also having issues. I upgraded a VR project to 4.16 and none of the 3D widgets are working properly (that is; buttons don’t respond in any way; neither click not hovered color), and it’s not even working in PIE. The problem appears to be related to the “interaction source” under “Interaction”. I have this set to Center Screen for VR and it’s fine in 4.15… I tried setting it to “Mouse” and then the widget works in 4.16, except of course my pointer doesn’t line up properly with the widget. So the widget is actually working but there’s a misalignment problem, something is off now in 4.16

Can someone please investigate this and let us know if it’s a bug or what we need to do to fix the problem.

avatar image ken_brueck May 27 '17 at 06:29 PM

Our buttons and sliders are working in VR but not scrollbars. Even more strange, we can click on the scrollbar's track (sometimes) to get the scrollbar to jump, but we can no longer click and drag.

avatar image Norkov May 30 '17 at 04:48 PM

In my case, after upgrading to 4.16, the colision boxes from other objects were blocking the Widget Interaction trace. To resolve this I changed some collision presets options in these objects.

avatar image AquilaEagle Jun 01 '17 at 02:48 AM

Yep, collision responses was it. I do a line trace from the camera and place a small sphere at the impact point (this is the VR cursor). Changed its collision to Ignore Camera and now it’s working properly. Thank’s Norkov.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I just updated to the latest build and it seems to be working fine now. Happy days!

more ▼

answered Jun 01 '17 at 07:48 PM

avatar image

Fractal_C
16 1 2 5

avatar image Stephan.Menzel Jun 07 '17 at 10:53 AM

Do you refer to 4.16.1 as the latest build? Cause I am using this and I am having the same problem.

avatar image Fractal_C Jun 07 '17 at 10:58 AM

Yeah it is (4.16.1-3466753). It's still working fine. Sorry to hear you're having the same issue with this build. Don't know what to suggest except verifying/reinstalling.

avatar image Stephan.Menzel Jun 07 '17 at 11:13 AM

That's the same version I got here, thanks for confirming. I will see if I can find the issue and comment here.

avatar image ken_brueck Jun 07 '17 at 12:20 PM

Even with 4.16.1 I still can't use scrollbars. I think my issue must be different than what some of the others in the thread experienced.

What specifically is broken for you? All buttons or just a few features?

avatar image Stephan.Menzel Jun 07 '17 at 12:25 PM

Hey Ken,

we have 3 widgets available for both desktop and VR. I can only test desktop right now but all of them appear to be broken as in "they don't react to anything".

I have debugged into the UInteractionComponent and it appears like the regular line traces it does to figure out which widget is underneath the pointer fails. The array of candidate widgets it keeps is always empty. Leading hypothesis here right now is that the character's capsule is suddenly blocking the line trace even though it worked fine since 4.10. I am investigating into how I can modify the capsule to not block whatever channel this line trace is being done with. Might be all BS though and it really is an engine bug.

avatar image Fractal_C Jun 07 '17 at 03:18 PM

If the Widget interaction Component works in any way at all then it's not the same issue I had, and possibly not do with the build. As I said, 'show debug' didn't even display the pointer, it was like it just wasn't there.

avatar image Stephan.Menzel Jun 08 '17 at 06:33 AM

Well, for what its worth, "show debug" won't show the pointer for me either but gathering from the code its not supposed to in input mode "Mouse". Couldn't try VR yet.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Why is this marked green - i dont see any answer or solution?

My widget interactor seems to be hitting the widget but with an offset so my widget controls register only when I click up and the right of them !?

more ▼

answered Jul 09 '17 at 03:58 AM

avatar image

Macw0lf
51 2 6 6

avatar image Fractal_C Jul 09 '17 at 10:40 AM

The solution was updating to a new build!

avatar image Stephan.Menzel Jul 09 '17 at 02:04 PM

Not for me. In my case, changes in the line tracing mechanism of said component made it unintentionally hit part of my character. Make sure, no collidable objects that block "Visibility" channel are in the way and you should be fine. This includes your character and everything visible or invisible that may be attached to it.

HTH, Stephan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Encountered same issue when migrating my stuff onto new version. Widget Interaction just didn't work, and I couldn't figure out why, exactly. Answers above I guess do work, but it didn't work for me. Anyway, tinkering around, I found out that in version .16 Widget Interaction Component behaves much rigidly in terms of proper setting up of parameters. You MUST have unique Pointer Index for EVERY Widget Interaction Component active ingame. That means, you should be sure to set to active only those components, that you really need (for spawned actors), and give each an unique pointer index if there are more than one active. It stops working completely (no debug traces drawn) if it encounters two components with the same index. Disable all but one (or set proper index), and it works as intended, and draws debug lines too. At least, that's how I understood this problem. Worked for me. Sounds silly and kinda unprofessional, but I forgot, that when you spawn Motion Controllers, you spawn two Widget Interactions. In .15 it worked fine, and I didn't notice any overhead, so I forgot about it completely.

more ▼

answered Jul 17 '17 at 03:33 PM

avatar image

Allottho
5 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question