x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sound concurrency broken when using -audiomixer

Sound concurrency is broken when using -audiomixer when playing in editor. Sounds will only have 1 concurrency, for example weapon fire will cut of every shot when the next one plays instead of using whatever concurrency settings that are in place. Also if simulating with 2 players in editor, the other client will have little to no audio at all.

None of these issues occur when launching the editor without the -audiomixer command line argument. (new audio mixer)

Product Version: UE 4.16
Tags:
more ▼

asked May 26 '17 at 01:57 AM in Bug Reports

avatar image

MADHOUSE
373 22 37 58

avatar image Thomas G ♦♦ STAFF May 30 '17 at 02:32 PM

Hello MADHOUSE,

I was unable to reproduce your issue on our end. I have a few questions that will help me investigate your issue further.

  1. Can you reproduce this issue in a new project?

  2. If so could you provide a detailed list of steps so I can reproduce this issue on my end?

  3. Could you provide screenshots of your issue?

Thanks!

avatar image MADHOUSE May 30 '17 at 03:34 PM

Greetings! Thanks for your reply.

Yes this happens in any and all projects, new and old.

The only thing to do is chose an audio file (slightly lenghty so the overlap play would be noticable), right-click the audio file and create audio que. Clicking the Play button in the audio que will have the audio cut off playback everytime it is played.

There really isn't much to screenshot: alt text

Sample audio que download: here

muchscreenshot.jpg (672.8 kB)
avatar image MADHOUSE Jun 12 '17 at 10:34 PM

Greetings, has there been any updates on this?

/Best Regards

avatar image Thomas G ♦♦ STAFF Jun 13 '17 at 04:38 PM

Hello MADHOUSE,

I was still unable to reproduce the issue you are experiencing. On my end, I was able to create an audio cue using the sound you provided. Playing these cues without a concurrency have each sound cut off when the new one begins. However, using a concurrency node resolves this issue on my end.

Could you post your settings for your concurrency node?

Thanks!

avatar image MADHOUSE Jun 13 '17 at 05:09 PM

Thanks for your reply.

I did not use any settings at all. I just right-click the audio file, create cue, and there it is. But this happens for any audio played using -audiomixer, regardless of settings. It makes no difference if it is left at default, or overridden and changed to some higher number 16-32

It is possible that the new audio mixer has hardware and/or software incompatibility issues I suppose if it dosen't happen on the machine you're testing with.

(edit: The audio works great with the old audio mixer ofcourse.)

avatar image JavierRamello Aug 04 '17 at 10:06 AM

I am experiencing the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

We have not heard back from you in a few days, and are still unable to reproduce the issue you were experiencing, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks!

more ▼

answered Dec 26 '17 at 05:30 PM

avatar image

Thomas G ♦♦ STAFF
7k 64 4 54

avatar image MADHOUSE May 21 '18 at 04:27 PM

This is still an issue in 4.19.3... I tested to uncheck concurrency override in the sound cue, and re-checked it, and then the editor crashed: https://pastebin.com/WidH2kxV

Concurrency with the new audio engine does not work, every cue it plays stops the previous one as if was only 1 in concurrency, regardless of any settings used, unfortunately rendering it completely unusable.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question