x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Importing Blender .FBX issues in 4.16

I'm fairly new to Unreal Engine 4/Blender, so this could just be me not understanding or having enabled/disabled options without remembering.

I've just started trying patch 4.16 and have found that none of my blender animations import properly, despite them all working just fine in 5.15.3. Some of them don't import at all.

My reproduction steps are opening up two new blank projects, one in 5.15.3 and one in 5.16, and attempting to import the same FBX file into each. All import settings in Unreal are the same between both versions.

This skeletal mesh won't import at all, saying that multiple roots aren't supported in 4.16 but working perfectly in 4.15.3. 5.15.3 is on the right in the video.
https://www.youtube.com/watch?v=189o205SfdM

My FBX files that do import have their animations scale miniaturized, while the mesh itself is the correct size. This issue is not happening to me in 4.15.3. 5.15.3 is again on the right. Testing with a single bone cube, a simple animation of it moving up and down.
https://www.youtube.com/watch?v=t3nxv-2fBwQ

Product Version: UE 4.16
Tags:
more ▼

asked May 26 '17 at 01:07 PM in Bug Reports

avatar image

Shadefox303
18 1 1 6

avatar image Takain May 31 '17 at 12:03 PM

got a similar problem http://prntscr.com/fe7mfx animations get imported but its so small its invisible (only happens in 4.16)

avatar image _Vagabond Aug 03 '17 at 02:19 PM

Hey , It is just AWESOME that the Armature bone is no more there, but having the same issue with 4.16. The animation scale is 10 time smaller than the original mesh. I managed to get the skeleton and the mesh imported in Unreal with even size by playing with settings in Blender and fbx exported but then the root motion is moving the object so so little that actually matches the objects movement if it is still small... Need fix for this so much !

Any news on this !? I couldn't find anything!

Thanks !

avatar image Takain Aug 04 '17 at 12:04 AM

check out the answers (not the selected one) on https://answers.unrealengine.com/questions/350406/blender-to-ue4-amaturebone-rotation-scale-problem.html i believe the problem is the scale, i also had to change scale on blender for Physics body to work, maybe its the same problem

for reference: "I had this problem with the default scene settings. After changing the scene units to meters and 0.01 scale (and resizing everything) things are now working perfectly. Are you sure you have applied the transforms in blender? Scene scale should be 0.01, armature scale should be 1.000 and the mesh scale should also be 1.000. The z dimensions of your mesh should say 2m or something in that ballpark. No scaling in the fbx export settings. This should fix the issue assuming you're using the latest blender version (2.76b at this time). " - cyaoeu

avatar image _Vagabond Aug 04 '17 at 05:53 AM

Hey, thanks for the reply. I am aware of the need to apply scaling in blender before export but the problem comes when you have an animated character. You can not actually apply scale to it in Blender because the animations get broken. I am having a model using Root motion animations which was done for another game engine which supports scaling of the whole FBX including the animation curves. Now when i want to use it inside Unreal i am having issues with the animations only and i think it is happening only when you enable the Root Motion in the animation asset. The mesh itself, i managed to import at proper size by using Uniform scale in import settings, but the animation assets are still 10 times smaller after model is imported. When i drag them to the scene compared to the Mesh itself they are much smaller.

I believe two two solutions are possible: having the possibility to apply scaling to animation curves in Blender with some tool (the best solution) or having Epic adjust the animation curves at import based on the scaling factor.

Btw i am using Blender 2.78c !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Its related to the fix on "Armature bone", some people were getting broken animations because of an extra bone called "armature", in 4.16 it removes that bone, but for us it NOW breaks the animations, if i rename the "Armature" to "Root", unreal engine wont try to delete it, and the animations will work

more ▼

answered May 31 '17 at 06:29 PM

avatar image

Takain
73 2 2 5

avatar image _Vagabond Aug 03 '17 at 02:38 PM

There is still problem when having root motion animations!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question