Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

.pak encryption missing in Project Launcher

The new .pak encryption options are missing in the Project Launcher. There also exists no encryption.ini or information on how to create one to set up the encryption key.

Product Version: UE 4.16
more ▼

asked May 29 '17 at 10:36 AM in Packaging & Deployment

avatar image

378 23 37 59

avatar image Estape Jun 05 '17 at 02:36 PM

I was able to find it by search for encrypted on Project Settings, but I can't find the Encryption.ini too.

avatar image MADHOUSE Jun 05 '17 at 03:07 PM

The packaging settings within Project Settings does not apply or are overridden by the Project Launcher, for example, the nativization needs a -nativize tag in the Project Launcher, regardless if you have the Project Settings for it or not, aswell as the option to encrypt ini files which are present both in Project Settings and the Project Launcher. To my understanding you would need to input some command into the Project Launcher or have a checker box for that feature.

avatar image MADHOUSE Jun 08 '17 at 02:22 AM

I've done multiple attempts at getting encryption to work, but nothing is happening..

"LogPakFile:Display: 35 files requested encryption, but no AES key was supplied! Encryption was skipped for these files"

I've added the key to the game.build.cs files, created an encryption.ini with the key in in the config folder, dosen't even matter if I hard code the AES key into the engine, nothing..

avatar image MADHOUSE Jun 13 '17 at 02:10 PM

Any advice is appreciated, ive explored multiple ways of setting up the Encryption.ini but nothing is working.

avatar image Estape Jun 13 '17 at 09:17 PM

Still nothing... I trying something stuff too, if I have something new I update here.

avatar image MADHOUSE Jun 20 '17 at 09:56 PM

Still no news on this, its very frustrating at this point. No one at all knows how to set this up?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

By random luck I came across this note in the release notes for UE4.15:

"Both AES encryption and pak signing are now configured from an Encryption.ini config hierarchy. See Config\DefaultEncryption.ini and Config\Windows\WindowsEncryption.ini in the ShooterGame sample project for an example of how to configure both encryption and pak signing."

My first test using this seems successful. If any one have any good advice on generating the 3 RSA keys I'd appreciate any help on this, but the AES part is easy to handle. \o/


edit: Note, this also works from the project launcher.

more ▼

answered Jun 28 '17 at 12:05 PM

avatar image

378 23 37 59

avatar image Estape Jul 25 '17 at 09:15 PM
avatar image eandmsz Aug 13 '17 at 07:32 PM

I'm trying this as well. Downloaded the free ShooterGame sample and used the DefaultEncryption.ini and WindowsEncryption.ini from that project. The DefaultEncryption.ini includes the keys, so if this file is missing then the compiler will complain that I didn't provide any AES keys, so the files will not be encrypted.

In the Project Settings / Packaging part I have both enabled: Encrypt ini files and Encrypt pak index.

Now the encryption seems to be triggering during packaging, but it fails with an ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Stage Failed. Missing receipt... PackagingResults:Error: Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game

How did you overcome this problem? Is there any other place where I need to set something up?

avatar image YanYuHongChen Dec 01 '17 at 07:24 AM

Same error with 4.18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question