x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Audio Resetting on Keyboard Input

I'm using UE 4.10.4

I downloaded some tracks on youtube as music for my game (I got permission to do so). When the music is playing and I quickly spam crouch ("s" button) while shooting projectiles ("left mouse" button) it seems this audio resets and plays from the beginning.

To me I don't see the relation between the keyboard input and the audio resetting. If anyone else has encountered this can you explain what is happening? Thanks so much!

Product Version: UE older version
Tags:
more ▼

asked May 30 '17 at 12:20 AM in Blueprint Scripting

avatar image

douggames234
6 1 6 8

avatar image douggames234 May 30 '17 at 02:21 AM

I tried this and thought it worked until I spammed the buttons harder: (Before importing the file, I need to go to the properties for the file and check the file as "Read-only.")

avatar image G4m4 May 30 '17 at 11:46 AM

Could you post a screenshot of the blueprint you're using? Also, are you really using this rather old version or do you mean 4.14 instead?

avatar image douggames234 May 31 '17 at 12:25 AM

I'm definitely using 4.10.4. I tried migrating to a newer version of the engine and the widgets/code was breaking. I just tested in 4.14.4 and the issue is still occurring also.

alt text

I don't think showing the images of the blueprint is too helpful as I am not accessing any sound components with shooting (I don't want to show too much of this blueprint).

alt text

My main character doesn't access any sounds anyways so this can't be the issue.

Here are the properties of the sound component which is restarting:

alt text

4.10.4.png (41.8 kB)
soundissue.png (50.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Sometimes it helps to come back to the code the next day with a clear head.

What I think is going on is there can only be a limited number of sounds going off at once. For example, if I shoot 100 bullets in 10 seconds some of the sounds are going to be cut out even if the sound is in another blueprint. By making the sound of my bullet part of my component rather than being called in the "play sound 2d" method, it seems like the issue was fixed:

alt text

more ▼

answered May 31 '17 at 01:00 AM

avatar image

douggames234
6 1 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question