x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Third Person Camera Collision With Floor

So I have a third person camera set up, along with a first person camera. Whenever I look below my character, I go right through the ground. Camera is set to Bock on the Landscape settings. I also set up a ViewPitchMax on my player but if I set it to not go through the ground, the first person is really useless as I can barely look up anymore in it. Even with that set, going down hills, I still clip through the ground quite a bit. Is there another way to collide or is this the best I can get? Let me know if you need to see anything, and I'll provide pictures.

Product Version: UE 4.14
Tags:
more ▼

asked May 30 '17 at 01:19 AM in Using UE4

avatar image

Ellezzerroxx
1 1 2 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

select your floor/ground. search under details "Collision", Change Collision Presets to Custom. From there you can choose collision Options for the Camera. Hope this helps.

alt text

collision.jpg (93.0 kB)
more ▼

answered May 30 '17 at 07:34 AM

avatar image

mrlz
61 1 2 3

avatar image Ellezzerroxx May 30 '17 at 09:03 PM

Like I said, I already have that set up and it is still not working.

avatar image mrlz May 31 '17 at 06:47 AM

I see that the problem is the Target Arm Length of your Spring Arm. select your camera the zero all out Location and Rotation from transform. to adjust distance of the camera from the player, select spring arm then adjust Target Arm Length to your desired distance, I'm sure this will fix your problem. alt text

springarm.jpg (147.0 kB)
avatar image Ellezzerroxx May 31 '17 at 11:54 PM

Tried that to no avail, does the same thing.

avatar image mrlz Jun 01 '17 at 07:02 AM

can you show screenshots? (viewport camera selected showing transform details, and spring arm selected, your floor/ground that is having the issue with collision details, and an In game that is showing the issue)

avatar image mrlz Jun 01 '17 at 09:24 PM

Cheers! Hope this picture explains everything

alt text

cjg7wn7 copy.jpg (600.4 kB)
avatar image Ellezzerroxx Jun 01 '17 at 09:33 PM

Yeah that works great thanks. Only thing is, and it's not a big deal, is that now the camera rotates around the character kinda weirdly, almost in a cinematic way. http://imgur.com/a/Ir7vD

avatar image mrlz Jun 02 '17 at 08:23 PM

you can set ThirdPersonCamera's translation to wherever you like, just take note that your camera should not exceed your CameraBoom's Arm Length. Hope this is helpful.

avatar image Ellezzerroxx Jun 02 '17 at 08:40 PM

Alright, got everything to work, thanks for all the help!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question