x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

lightmap/uv problem

Hi,

I'm having some trouble with my lighting in UE 4.15

I have some objects that display weird lighting, and I can't understand why..

This issue is this (detail lighting-view): alt text

My lightmap looks like this: alt text

The objects are split into seperate objects. They are modelled in Rhino, uv-mapped in Rhino, and then imported as a fbx. I have tried unwrapping the UV's in blender, with the same result.

My lightmass-settings are in the image beneath here, and I don't think it is an issue with quality-levels?: alt text

And finally, i have this issue as well (detail lighting-view): alt text

As you can see, the shadows are really bad, both around the railing, both also on the walls. This one I suspect have something to do with the pointlights? Because before I had them in my scene, i got smooth surfaces with lower lightmass-settings.

I would greatly appreciate any suggestions, I have been working on these issues the last week, and I can't figure it out.

EDIT: Sorry, forgot the settings for the object itself: alt text I have tried importing one where I unwrapped the UV's in Blender - still the same result.

Product Version: UE 4.15
Tags:
3.jpg (196.6 kB)
1.jpg (327.1 kB)
2.jpg (109.0 kB)
4.jpg (140.0 kB)
5.jpg (265.9 kB)
more ▼

asked Jun 02 '17 at 11:29 AM in Rendering

avatar image

nermin_91
8 1 2 4

avatar image Emiel97 Jun 03 '17 at 09:35 AM

Light building is just terrible in Unreal Engine. It never works. You could increase the lightmap resolution or just make all your lights 'Moveable' to disable light building

avatar image nermin_91 Jun 03 '17 at 01:52 PM

If i increase the lightmap resolution, then the white on these will look different than the white on the walls, right? It's my understanding that you want the size of the squares to match as much as possible (in lightmap res-view in editor).

Also, moveable light doesn't give me the quality I need, and I want this to be able to run smooth for VR-purposes as well as on screen. FPS would take a huge hit if all my light we're moveable, right?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found a solution.

Had to tweak the lightmap resolutions for pretty much everything in my scene.

more ▼

answered Jun 05 '17 at 08:05 AM

avatar image

nermin_91
8 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question