Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaging error - "unknown error", no clue where it's coming from

I have a project I've been working on a while done entirely with blueprints. But now when I try to package it gives me these errors, and I'm not quite sure what's going on.

Since I was last able to package normally I have done a whole bunch of things, admittedly: I changed the name of the project, added in a bunch of UI widget to use as titles and splash screens, added in a bunch of actors. But I've been trying to delete every one of those thing one at a time to see if I can find where the problem is, and no success. I've also changed manually the name of the projects in the default config .ini files, but to no avail.

Anybody has any idea?

This is the last bit of the log, with all the errors.

 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: === Critical error: ===
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: 
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000010
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: 
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-CoreUObject.dll!0x00000000EC9BD746
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UMG.dll!0x00000000EA015FBE
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UMG.dll!0x00000000EA015EF1
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UMG.dll!0x00000000E9FB6153
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UMG.dll!0x00000000E9FD9D33
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-CoreUObject.dll!0x00000000EC9AC697
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-CoreUObject.dll!0x00000000EC997186
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UnrealEd.dll!0x00000000EAE4B640
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UnrealEd.dll!0x00000000EACFC6B4
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UnrealEd.dll!0x00000000EAD0822E
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UnrealEd.dll!0x00000000EABB6D72
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-UnrealEd.dll!0x00000000EABDBA21
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-Cmd.exe!0x0000000055377B8F
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-Cmd.exe!0x000000005536EEDA
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-Cmd.exe!0x000000005536F12A
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-Cmd.exe!0x0000000055380CF9
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: UE4Editor-Cmd.exe!0x0000000055381A1F
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: KERNEL32.DLL!0x0000000032472774
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: ntdll.dll!0x0000000033C20D61
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: ntdll.dll!0x0000000033C20D61
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: 
 UATHelper: Packaging (HTML5): Cook: LogWindows:Error: end: stack for UAT
 UATHelper: Packaging (HTML5): CommandUtils.Run: Run: Took 30.7900277s to run UE4Editor-Cmd.exe, ExitCode=3
 UATHelper: Packaging (HTML5): Project.Cook: Cook failed. Deleting cooked data.
 UATHelper: Packaging (HTML5): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Cook failed. ---> AutomationTool.CommandletException: BUILD FAILED: Failed while running Cook for C:\Users\rubin\Documents\Unreal Projects\Recess2\Recess2.uproject; see log C:\Users\rubin\AppData\Roaming\Unreal Engine\AutomationToo
 UATHelper: Packaging (HTML5):    at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
 UATHelper: Packaging (HTML5):    at AutomationTool.CommandUtils.CookCommandlet(FileReference ProjectName, String UE4Exe, String[] Maps, String[] Dirs, String InternationalizationPreset, String[] CulturesToCook, String TargetPlatform, String Parameters)
 UATHelper: Packaging (HTML5):    at Project.Cook(ProjectParams Params)
 UATHelper: Packaging (HTML5):    --- End of inner exception stack trace ---
 UATHelper: Packaging (HTML5):    at Project.Cook(ProjectParams Params)
 UATHelper: Packaging (HTML5):    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
 UATHelper: Packaging (HTML5):    at BuildCookRun.ExecuteBuild()
 UATHelper: Packaging (HTML5):    at AutomationTool.BuildCommand.Execute()
 UATHelper: Packaging (HTML5):    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
 UATHelper: Packaging (HTML5):    at AutomationTool.Automation.Process(String[] Arguments)
 UATHelper: Packaging (HTML5):    at AutomationTool.Program.MainProc(Object Param)
 UATHelper: Packaging (HTML5):    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
 UATHelper: Packaging (HTML5):    at AutomationTool.Program.Main()
 UATHelper: Packaging (HTML5): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
 UATHelper: Packaging (HTML5): BUILD FAILED
 PackagingResults:Error: Error Unknown Cook Failure
Product Version: UE 4.16
more ▼

asked Jun 02 '17 at 07:07 PM in Packaging & Deployment

avatar image

Erik 256
3 1 2 3

avatar image Erik 256 Jun 02 '17 at 07:18 PM

Might it have something to do with this kind of arrangement? It's in a widget blueprint. On editor start-up they were giving me a bunch of weird warnings that disappeared as soon as I compiled again. alt text

capture.png (145.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Solved it! As it turns out the problem was with the widget blueprints, but just because to kick 'em off at specific times, I was creating them and adding them to widget in Game Mode after checking my the "time" variable that ruled the in-game time every tick.

I am now using a timeline in the level blueprint, instead, which makes a lot more sense, but it was 5am and hadn't slept in a couple of days, so shut up!

Not sure if it was because I did it in Game Mode or because of the every tick bit (I guess it would be easy to test, but after days of banging my head on the keyboard to figure this out, I think I'd rather package and forget about it a while).

Thanks, and have a nice weekend.

more ▼

answered Jun 03 '17 at 05:37 PM

avatar image

Erik 256
3 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried reinstalling the Engine? Its odd that something like that was throwing errors.

I am pretty sure Unreal has never been the best at building for HTML. I have had problems with it in the past. Something as basic as this shouldn't be throwing errors.

Have you disconnected them from Event Construct node and see if it will build?

more ▼

answered Jun 02 '17 at 07:25 PM

avatar image

150 6 10 17

avatar image Erik 256 Jun 02 '17 at 07:30 PM

Yes to all. Only thing I haven't tried (Not even sure I can) is reinstalling 4.15, and try opening it with that, maybe it's the new version?

And it's giving the same errors even when I package for windows.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question