x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to normal export blender model in ue4?

I create the .fbx file in blender then import this file in ue4. I have my model in incision in ue4. How to solve this problem?alt text

Product Version: UE 4.15
Tags:
more ▼

asked Jun 03 '17 at 03:45 PM in Using UE4

avatar image

KyklsDro
9 2 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I use blender -> ue4. Generally found you need to export the face smoothing group in the fbx export settings.

Not knowing what the original model looks like - what's the exact problem?

more ▼

answered Jun 03 '17 at 04:40 PM

avatar image

theonecalledtom
1.3k 61 68 271

avatar image KyklsDro Jun 03 '17 at 05:20 PM

in 3 is the original model, in 4 is in the ue4 after exporting

avatar image theonecalledtom Jun 03 '17 at 05:25 PM

Looks like your normals are inverted? If you display them in blender do they point the right way? If not you can try (in edit mode) mesh -> normals -> recalculate outside.

avatar image KyklsDro Jun 03 '17 at 05:55 PM

not working, maybe i need to change something in importing setting in ue4?

avatar image theonecalledtom Jun 03 '17 at 06:19 PM

The normals look right in blender?

You could be inverting your axis' somewhere (not sure what settings are available for this but you might find them in either/both export and import settings.

Another thing that comes to mind - if you applied transformations to the object in blender I've found (a couple of years ago now, not tested recently) that they don't come through properly. My general practice is to apply scaling, offsets etc to the vertices.

If you're still having problems later upload your .blend file and I'll have a play with it.

avatar image KyklsDro Jun 03 '17 at 07:26 PM
avatar image theonecalledtom Jun 03 '17 at 09:35 PM

Looks like the problem is with your normals - they are pointing inward:

your normals

Recalculate outside did work for me - you have to select all the verts for it to work though (A when in edit mode - the mesh turns orange when selected).

They should look like this:

like this.

To display them in blender - there are toggles on the right hand view pane.

toggles

Hope this helps - if it does then just accept my answer above!

avatar image KyklsDro Jun 04 '17 at 11:06 AM

ok, this works, thanks, but now texture is transparent inside the model.alt text

now.png (526.1 kB)
avatar image theonecalledtom Jun 04 '17 at 02:36 PM

Apparently "Recalculate Outside" doesn't get the inside normals deeper in the urn.

To fix that in blender:

  1. In solid edit mode [Z toggles wireframe and solid] hit C, this gives you a selection cursor that you can resize with the mouse wheel. Click to select vertices and shift click or middle mouse button click to unselect. Very useful...

  2. Select something at the bottom of the urn

  3. In the select menu pick "Linked" OR ctrl-L. A menu will appear at the bottom left select "Normal" as your delimit. This should select only the broken faces (it did for me).

  4. Once you have the faces you need to fix selected go mesh->normals->flip.

  5. ReExport

  6. ReImport into UE4

  7. Profit

link text

avatar image theonecalledtom Jun 04 '17 at 04:20 PM

My personal experience with Blender is that it has a non trivial learning curve and some seriously powerful tools to play with once you start getting the hang of it. Amazing package for free!

Probably took me 20 hours to get the modelling basic worked out. A lot maybe but you get a lot of power for that investment.

Youtube tutorials are awesome!

Good luck :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question