x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level Change causing actors to freak out

Ok, so I have a collection of actors with simulate physics enabled. These behave exactly as you would expect and as I want the too most of the time. Usually what I want them to do is roll around a little.

alt text

The issue happens whenever I move from my tutorial level into the main level. This causes them to fly off in random directions as if AddImpulse has been used on them. (It hasn't)

alt text

I've checked, they are not clipping into the group or anything like that. No other external forces are acting on them. Anyone have any ideas?

Product Version: UE 4.15
Tags:
more ▼

asked Jun 06 '17 at 09:26 AM in Blueprint Scripting

avatar image

Jiyko
34 5 8 9

avatar image Jiyko Jun 06 '17 at 10:34 AM

Too add to this, it seems the collision with a box in the actors parents in not registering any on overlaps when the level is loaded in. I also tried raising them off the landscape, no success with that either.

avatar image PatrickRegal Jul 11 '17 at 05:54 PM

I'm having a similar problem, I have a table with many different actors placed on it and when I load into the level from a different level several of them, consistently the same actors, start moving all over the place as if a thruster or something was attached to them. If I disable physic on the objects that does stop the movement. One of my objects was essential just a cone and through rigorous trial and error after removing every single difference from a normal default cone actor It seemed what was causing the movement was a collision sphere I had on its tip. However, when trying to put a new collision sphere back on it, even copy and pasting the exact same collision sphere from a copied blueprint, no change, movement still stopped. I'm wondering if there has been any progress on this?

avatar image Jiyko Jul 12 '17 at 02:06 PM

I never really got a solution to this! The issues was resolved for me when we removed the template static meshs and added in the production ones. Sorry I can't be more help!

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question