x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Skeleton root bone scale incorrectly set to 1 in animations after "Imported bone transform is different" error, resulting in smaller/bigger meshes in animation

The root bone scale in a skeleton is incorrectly set to 1 in animations after you import a skeletal mesh getting a "Imported bone transform is different from original. Please check Output Log to see detail of error". The error itself is caused by the Blender exporter scaling all of the bones in a rig instead of only the root bone.

Because the root bone scale is set to 1 incorrectly the animations look wrong. If the mesh was scaled 100 times the root bone scale should be 100 in animations too, but in the case of the error it's set to 1 so the character is 100 times too small in the animations while looking fine in Persona skeleton/mesh mode.

FBX files here:

To see normal scaling behavior:

  1. Import blender001scale.fbx with Import Uniform Scale set to 10 and importing animations.

  2. The skeleton root bone has 10 scale in the skeleton view.

  3. The skeleton root bone has 10 scale in the animation view.

blender001scale.fbx was exported using metric 0.01 unit scale in Blender, which works but causes issues in other parts of Blender.

To see faulty scaling behavior:

  1. Import blender1scale.fbx with Import Uniform Scale set to 1 and importing animations.

  2. You get an error saying "Imported bone transform is different from original. Please check Output Log to see detail of error" because on export from Blender all bones were scaled instead of just the root bone.

  3. The skeleton root bone has 100 scale in the skeleton view.

  4. The skeleton root bone has 1 scale in the animation view. This is a bug, it should be set to 100 like in the skeleton view. Because of this the animation is tiny.

blender1scale.fbx was exported using metric 1 unit scale in Blender, which at the moment causes issues with UE4 but works perfectly with other areas of Blender.

Product Version: UE 4.16
Tags:
blender fbxs.zip (2.7 MB)
more ▼

asked Jun 07 '17 at 02:03 PM in Bug Reports

avatar image

cyaoeu
143 9 14 23

avatar image Glitchdove Jun 07 '17 at 06:18 PM

Sorry if I'm posting this comment in the wrong place or something, only creeped before and never posted! (Thanks for making this post btw)

I wanted to say that I have this issue with the newest version of unreal - spent all day yesterday fidgeting with the settings in both blender and UE, no luck. I moved back down to 4.15 this morning, reset all of my export/import settings to how I usually do it, and it imported just fine.

It's really frustrating - look forward to seeing this corrected.

avatar image aWinter Jun 30 '17 at 03:10 PM

Think this may be related to the crude implementation of the armature bone removal. We had to modify the blender exporter so the fbx don't get recognized as blender file, keeping the armature bone untouched. We don't have any Issues this way.

There are many people who DON'T want or need the Armature Bone REMOVE d So please Epic... If you touch the Blender fbx Importer again, make sure that you expose a bool to the import options or console command to keep the armature untouched. Thank you.

avatar image huwp Jan 08 '18 at 07:43 AM

A workaround that I found: Rename "Armature" to something else.

I personally call it "Root" and have it mimic the root bone.

avatar image cyaoeu Jan 08 '18 at 12:13 PM

That's not a great workaround because it means you can't animate root motion in pose mode. I would rather use the 0.01 scene scale workaround until this bug is fixed.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question