x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes when painting on certain landscape tiles.

My world is built out of tiles using the world browser. For no reason I can find, when ever I paint certain tiles, my editor will crash. Can someone tell me why or how to fix this? This literally makes me unable to work on my project anymore.

Product Version: Not Selected
Tags:
more ▼

asked Jun 27 '14 at 07:39 PM in Bug Reports

avatar image

xC0DEB10C
303 12 117 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Could you assign a crash log? It hard to say what might me wrong without it.

more ▼

answered Jun 28 '14 at 05:50 AM

avatar image

ddvlost STAFF
1.3k 18 7 48

avatar image ddvlost STAFF Jun 28 '14 at 07:32 AM

Could you paint some foliage on a landscape tiles that cause crash, and the check if sculpting still cause crash on them?

avatar image xC0DEB10C Jun 28 '14 at 09:38 PM

Ok, so this is my log: http://hastebin.com/tehalenuku.tex and here is the dmp: http://wikisend.com/download/826594/Dump276410336.dmp - my engine version is 4.2.0 self compiled. The log says this is the line that crashes: LayerNoWeightBlends[LayerIdx] = Allocation.LayerInfo->bNoWeightBlend;

Adding foliage and sculpting seems to work, but painting will make it crash/close.

Some things I tried:

  • Recreating the paint LayerInfoObjects doesn't work

  • Applying a different material to paint doesn't work.

  • Sculpting the landscape before trying to paint doesn't work.

  • Adding foliage to the landscape before trying to paint doesn't work.

Btw, is there any ETA on when 4.3 is coming out? Also, if you have any code snipplets that would fix the issue, I can implement them. But some trick to re-validate/fix the tiles would do as well.

avatar image ddvlost STAFF Jul 01 '14 at 02:55 AM

It would helpful if you can recreate this issue in a isolated project and send that project to me. So I can fix the crash. I have tried to reproduce it without any success. It seems like one of the LayerInfo objects is null. Probably this could happen when you create new LayerInfoObject asset, assign it to a landscape layer, save the map without saving the created asset. So next time you open this map references to a LayerInfoObject will be lost.

avatar image xC0DEB10C Jun 29 '14 at 08:46 AM

Oh well, I recreated the tiles. Hope I can keep it from corrupting again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question