x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Open Level blueprint not working on mobile

Hi,

When I use the 'Open Level' blueprint in my game, everything works fine in the editor/emulator, but when I test it on any iOS device it always loads the default level instead of the level it has been told to.

I have seen a couple of posts about this but there has been no response. Do you have any suggestions of what the problem could be or if there are any workarounds? I am currently blocked by this and would appreciate any help.

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Jun 28 '14 at 06:03 PM in Bug Reports

avatar image

Epok
65 6 10 65

avatar image tweedie Jul 13 '14 at 12:30 PM

Bumping this, I still can't find a work around. I had a build that magically decided to work once (I thought I must have changed a setting that I couldn't remember), but now it's back to opening whatever's listed as the default map.

I'm launching on an iPhone 4S using 4.2.1 All works fine in the editor and mobile preview. Would be nice to hear a 'We've noted this bug and it's being fixed', but I haven't read a single answer mentioning that or even a temporary fix on any of the older forum questions. Kind of makes mobile development impossible for multi-level games.

avatar image Alt101 Oct 24 '14 at 03:24 PM

We are running into this issue as well on our project. Any update on this?

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

I found a work-around: try packaging the whole project and then putting the file on your phone through iTunes. It's obviously longer than launching straight to the device but everything works as expected for me when I do it this way.

Hope it works for you too.

more ▼

answered Jul 15 '14 at 10:51 PM

avatar image

Epok
65 6 10 65

avatar image tweedie Jul 16 '14 at 09:26 AM

Thanks very much for this info! Interesting bug then... I'll give it a try when I next have time to work on my project. Haven't put a package on my phone using iTunes before, but I'm sure there's a lot of info about that on the apple forums :) Thanks again!

avatar image Steve Hardister ♦♦ STAFF Oct 24 '14 at 08:41 PM

In order to report this as a bug, I'll need some more information about the system you're developing on. Please provide more information about your Mac's specs. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary). (-Or your dxdiag if you happen to be on a Windows machine.)

We also need the following information from the "System Report:" Apple menu >About This Mac>More Info> System Report>Hardware (All information listed in the "Hardware Overview.") You can cut and paste this information or provide screen shots, whichever is more convenient.

Thanks,

(comments are locked)
10|2000 characters needed characters left

We ran into this issue as well. It isn't mentioned anywhere but you're going to want to include all of your maps in the "DefaultEditor.ini" file. Add the following code into your DefaultEditor and you'll be good to go

 [AlwaysCookMaps]
 +Map=/Game/Maps/Map_Name_01
 +Map=/Game/Maps/Map_Name_02
 +Map=/Game/Maps/Map_Name_03

This solved the issue for us on iOS and Android builds.

more ▼

answered Oct 28 '14 at 09:00 PM

avatar image

Alt101
81 4 55 14

avatar image Epok Nov 16 '14 at 07:06 PM

Thank you! That's one less annoyance gone from my work flow :)

avatar image MeshMyster Nov 12 '15 at 11:28 PM

there are so many defaulteditor.ini files, which one do I modify?

avatar image Samantha Sutton ♦♦ STAFF Nov 13 '15 at 05:52 PM

Have you tried adjusting the DefaultEditor.ini that's in the Config folder?

avatar image AeXaRd Aug 16 '16 at 09:28 PM

Thank you man! It's Work for me ))

(comments are locked)
10|2000 characters needed characters left

As far as I know, when you deploy your game using the "launch" button, Unreal understand that you are going to test the currently opened level, so by default it doesn't deploy other levels. If you want to test the transition between levels you have two options:

  1. File > Package Project > iOS and use the iPhonePackager (in my case, because I work on Windows) to deploy the *.ipa file in your device.

  2. Edit > Project Settings > Packaging. Inside this you have a section also called Packaging. Show advanced options and set "cook everything in the project content directory" option. If you only want to add a few levels, use the option "list of maps to include in a packaged build"

more ▼

answered Oct 06 '17 at 09:28 AM

avatar image

monkeyEclipse
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question