Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my FBX taking a long time to import?


i have an animated fbx i made in zbrush and animated in cinema4d. it has 30 bones and around 20k polys. i triangulated the mesh in cinema4d. i have done this exact workflow for two other meshes and it worked fine. they just had a slightly lower poly count. it has been importing for the past 2 hours and i think i'm just going to give up. 20k is not a lot, right? i know it's more than ideal but still....

what are some things you can do to an fbx so that it does not take so long? should i try to get the 20k count down? it was 10k but then i triangulated it. are 30 bones way too many? the animation is very simple, just 60 frames animated like 10 bones back and forth.

here is a link to fbx if you're curious: https://mega.co.nz/#!ZtdjFQRT!GwDvVUEBmVFRdJhuOceJnuxbaZIoT46TQjkIiCi8S80

i have 16gigs of ram, win8, nvida geforce 250 (i know i need to upgrade), 8core 4ghz amd processor.

edit - the mesh imported fine without the bones/animation. any reason why 30 bones would throw off an import?

thanks so much for any help!

Product Version: Not Selected
more ▼

asked Jun 28 '14 at 09:29 PM in Using UE4

avatar image

36 7 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think it has something to do with the model. Try to import the mesh only without the bones and animation and see if imports properly.

more ▼

answered Jun 28 '14 at 10:28 PM

avatar image

16.9k 671 167 678

avatar image treebykooba Jun 30 '14 at 04:12 PM

thanks for the help. the mesh imports fine without the bones. with the bones it will not import in any reasonable time that i'm willing to wait.

what are some best practices for bone chains in cinema4d to ue4? i have a root bone and then 29 children of the root. as i said - this has worked fine in other meshes. can't figure out why not for this one.

avatar image Jacky Jun 30 '14 at 04:25 PM

I have no idea what could be wrong since i have no Cinema4D experience. You can check those threads if you like and maybe even start a new one in the forums in order to get more help.



avatar image treebykooba Jun 30 '14 at 07:58 PM

ok i figured it out sort of. it can only handle so many weight changes. the more i change the weights of the bones the less likely it is to import. pretty weird/annoying. anyone know anything about this? thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question