x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does my texture look blurry inside UE4?

Hi,

I'm trying to let UE4 display a tree model I made. I'm importing the tree as a .fbx file (my modeling software only exports to .dae and I used the Autodesk FBX Converter to get the .fbx file) and I'm importing the texture as .png. After importing and applying the texture, UE4, as expected, creates a material from the texture.

The texture becomes, however, very blurry after being imported into UE4. The texture is very small and UE4 seems to perform some strange kind of optimization on it, making it blurry instead of pixelated (which would be expected and fine).

I attached a screenshot that compares the look of the texture file in UE4 to the way it's supposed to look:

alt text

As you can see, the texture is scaled in a very strange way. The look on the right would be completely fine, since the model is made of small cubes (a kind of "voxel" look) and the texture file only needs to contain the colors of the cube surfaces).

What changes do I need to make to have the texture look as it's supposed to?

Thanks a lot

Phil

EDIT

I scaled the texture manually using GIMP - the texture now looks fine after the import. When scaling with GIMP, I had to set the interpolation mode to "none" or the texture would look exactly like in UE4.

Since this seems to be the problem, is there a way to change the way UE4 interpolates? Manually scaling every texture seems like unnecessary work and increases file sizes. Even the scaled version is slightly blurred in UE4, so simply disabling that algorithm would make things a lot easier..

Product Version: Not Selected
Tags:
more ▼

asked Jun 29 '14 at 11:27 AM in Using UE4

avatar image

MrPhil
63 8 9 12

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

If you want to have sharp pixel art you need to open the texture properties by double clicking the texture in the content browser and changing filtering to nearest neighbor.

This thread has a picture of where the setting is: link

more ▼

answered Jun 29 '14 at 02:52 PM

avatar image

RyanB STAFF
2k 55 24 118

avatar image MrPhil Jun 29 '14 at 09:58 PM

That fixed it - thanks a lot!

avatar image Hermitttt Dec 17 '16 at 11:18 PM

that didn't fixed it at all. it made it slightly more accurate. but far from what the original looks like. sighs

avatar image Theon Jan 13 '18 at 04:55 PM

Doesn't fix it.

(comments are locked)
10|2000 characters needed characters left

I had the same problem I changed the Texture Group to "2D pixels (unfiltered)" This worked for me on UE4 4.10

more ▼

answered Jan 25 '17 at 04:29 AM

avatar image

AussieViking117
6 1

avatar image Greywacke Sep 14 '18 at 06:26 PM

This worked great, thanks.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question