x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to install UE4 to a separate drive?

Ok this should be a very simple process so my apologies if making a post isn't necessary, but I have done a little research and haven't found my answer.

I have a new SSD that I bought specifically for UE4. I want all of my game development stuff on this storage device and am wondering why I can't seem to install UE4 on it. When going through the installer I can select the directory which I designate to the SSD I want, however, this only installs the UE4 app (or 'hub', whatever it's called). At this point I have to open the app and install the engine itself, this is where I'm having the problem. All I see is the big yellow install button and when I click it, it's starts the install without asking me where to designate it. Any help is appreciated!

Product Version: Not Selected
Tags:
more ▼

asked Jul 01 '14 at 09:41 PM in Installation & Setup

avatar image

Skisma
63 7 12 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Harley,

When installing the Launcher through the downloaded MSI, you should select the drive that you want the UE4 installations to appear on as currently they will all be installed alongside the Launcher installation.

So I think what you have done is correct - hitting the install button should install UE4 to the SSD along with the Launcher?

Let me know if you think this is not the case for you :)

Thanks,

Leigh

more ▼

answered Jul 02 '14 at 09:05 AM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image Skisma Jul 02 '14 at 02:38 PM

Leigh,

Thanks for the reply, I don't think this is the case for me. First things first, I'm not sure what is considered what, but it sounds like the MSI is the app I'm referring to that I downloaded from the internet and the launcher is the engine. If this is so then what happened for me is, I downloaded the MSI from unrealengine.com to my "Unreal (E:)" drive. I ran the installer and installed it. I opened it up from the desktop shortcut that was created from the install. Then I clicked 'Install 4.2.1' from within the MSI. It ran the installation process and installed to my (C:) drive, the drive that houses my operating system.

avatar image leighswift STAFF Jul 02 '14 at 06:49 PM

The msi that you download installs the Unreal Engine 'Launcher' - a small app that you use to manage you engine installations and visit the Marketplace from.

The msi installation should have a screen like this where you can change the install location:-

alt text

If you do not see the change button then it is because the msi has already been installed, and to move it you will need to uninstall it from the windows control panel and then run the msi again.

Does that help?

avatar image Skisma Jul 02 '14 at 08:14 PM

Swifty,

Thanks for the clarification on that terminology. Unfortunately this doesn't help because I have seen this screen and selected the drive I wanted, my (E:) drive. I have no issue with that. The problem is once I install the launcher to my E: drive, the engine itself doesn't install there, only the launcher. Once installed (to my E:), I open up the launcher and within it install the engine/editor 4.2.1. This is where I'm having issues since this isn't installing to my E:, but instead my C:. Does that make sense?

avatar image leighswift STAFF Jul 03 '14 at 08:39 AM

Ahh ok. Yes makes sense, sounds like incorrect behaviour. Could you upload some things for me to take a look at?

The log files for the launcher, could you zip up this folder and attach it:- C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

The manifest files for the launcher, again, please zip up the folder and attach it:- C:\ProgramData\Epic\UnrealEngineLauncher\Data\Manifests

This will help me to see if we can figure out why this may be happening.

Could it also be that the installations on C are just left over from a previous time? And there are also new ones going onto the E drive along side the Launcher. When you navigate to the Launcher installation folder that you chose in the MSI, what do you see?

avatar image Skisma Jul 03 '14 at 02:16 PM

Ok yes I'll provide all of that info. It won't be until tonight though because I'm at work. I'll update this thread later tonight with all of your requests. Thanks!

avatar image Skisma Jul 04 '14 at 04:29 PM

Ok the two file paths you explained for the two folders you want me to upload aren't on my machine. I can't locate my logs folder nor manifests. However, I did attach some screenshots of what is installed on my E: drive (the drive that's supposed to have everything on it.

alt text

alt text

e-1.jpg (74.7 kB)
e-2.jpg (72.6 kB)
avatar image Skisma Jul 04 '14 at 06:36 PM

UPDATE: I fixed the problem!

This time around, I uninstalled EVERYTHING and did a fresh re-install. Last time I uninstalled everything except for the downloaded sample projects because I didn't want to have to re-download all of them.

I guess this was the source of the problem.

You can close this now. However, I do have another question that has gone unnoticed. If you don't mind, could you take at look it it: https://answers.unrealengine.com/questions/63263/static-meshes-have-no-materials-when-i-drag-them-i.html

Thanks,

Skisma

avatar image leighswift STAFF Jul 07 '14 at 03:02 PM

Seems like an odd one shame we couldn't figure out why but it's great that you can get on now :).

Looks like Ben is on that other thread you mention, I'll give him a nudge :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question