x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Acceleration and deceleration

I want to make character which smoothly starting running and smoothly stopping to idle. In first case I set "Max acceleration" to 1000 and it works good but when I try set "Braking deceleration" to any value it seems to have always the same behavior for every value (1 or 1000 it doesn't matter). My character always immediately stop...

Have you any idea what I'm doing wrong?

Product Version: Not Selected
Tags:
more ▼

asked Jul 02 '14 at 12:04 PM in Using UE4

avatar image

kodmistrz
334 54 83 103

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hey kodmistrz,

There are two factors in play when there is no acceleration for your character: Ground Friction and Braking Deceleration Walking. The default value for Friction is 8.0, which is quite high, so that is stopping your character quickly. Friction is relative to velocity, and Deceleration is applied constantly over time. Most likely the Friction is dominating the Deceleration.

Try lowering the Ground Friction value in the Character Movement component to 1.0 or 2.0, and then play with the Braking Deceleration Walking value.

Hope that helps!

Ben Halliday

more ▼

answered Jul 02 '14 at 10:33 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Also, try setting the "Use Separate Braking" variable to true in the "Character Movement" component. And then set the "Braking Factor" (or similar name) low, to like 0.1 or something. This will cause the character to gradually lose speed when you're running and then release the input.

It's safer this way than setting friction low because that will cause the character to slide around all the time.

Hope this helps!

more ▼

answered Aug 29 '18 at 08:03 PM

avatar image

Adam Kareem
21 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For me. MaxWalkSpeed=125, GroundFriction=0.75, Deceleration=128, Acceleration=128 gives me a somewhat believable movement, of course those are matched to my animations to avoid skating across the floor.

more ▼

answered Dec 16 '18 at 12:49 AM

avatar image

Rukgul
33 2 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For character acceleration, better value (Max Acceleration) for example 300

To slow down a character, it's better to change two values (1.Braking Deceleration walking for example "300" and 2. Braking Friction Factor for example "0")

more ▼

answered Apr 01 '19 at 08:46 AM

avatar image

Низами
11 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question