x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Foliage isnt darker in the shadows of landscape or static mesh

alt text

The right side on the pic is lightened by a dircet light, the left side is in the shadow of the landscape.

You can see that the foliage grass is not darker in the shadows of the landscape or the cylinder (static mesh) only the shadows of the trees (foliage) makes the grass darker.

In the foliage-setting I have adjust that the foliage grass doesn't cast shadows, the tree, the landscape and the direct lighting have the option "cast shadows" on

Is there a way to make the foliage shadowed by landscape- and staticmesh-shadows?

Product Version: Not Selected
Tags:
foliage_shadow.jpg (234.9 kB)
more ▼

asked Jul 04 '14 at 05:09 PM in Rendering

avatar image

wARmAcH1n3
226 20 20 25

avatar image wARmAcH1n3 Jul 06 '14 at 11:17 AM

Can someone tell me if this is a bug, false adjustment or this isn't implemented in the engine?

I'm using 4.2.1

avatar image RimmyD Jul 07 '14 at 01:54 AM

Just a quick question, are you using static lights? I am curious if this is an issue with just needing to rebuild lighting.

Also if you place one of the meshes you are using for foliage in the same spaces (not as foliage type, just as a staticmesh) does it light properly?

avatar image wARmAcH1n3 Jul 07 '14 at 11:07 AM

Yes the landscape use static shadows. If I put the grass as a static mesh and not as a foliage on the landscape (with "Cast shadows"=off) the grass are darker in the shadows of the landscape (but if I light them with a spot light [which I attached on the player as a lamp], the static meshes get only lighten on the side which faces the sun, the other side keep dark even if I light them with my lamp)

I found this thread, it seems I'm not the first person with this problem https://forums.unrealengine.com/showthread.php?3268-Nature-Environment-in-UE4

avatar image Lovecraft_K ♦♦ STAFF Jul 07 '14 at 04:20 PM

Hi wARmAcH1n3 -

You said you were using a "direct" light did you mean directional light and if so what is it set to (Static, Stationary, or Movable)? Try Stationary and see if the shadows return. Also make sure you are building your lights.

Thank You

Eric Ketchum

avatar image wARmAcH1n3 Jul 08 '14 at 01:08 AM

yeah I meant directional light, it is setted as Stationary. If I set it as movable it works, but I don't want to have the sun as totaly dynamic light because higher performance.

avatar image Oscar Cooke-Abbott Jul 07 '14 at 05:06 PM

I am sorry but I do not see a problem with that picture? could perhaps demonstrate by putting the foliage in the shadow of a mountain to better demonstrate? Then I could see the problem and help :)

avatar image wARmAcH1n3 Jul 08 '14 at 01:12 AM

in the half of the picture at the bottom you can see the border between shadow and no shadow (with brown color) (the sun is on low position and cast long shadows). the shadow of the cylinder doesn't shadow the grass too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This is a missing feature, translucency does not receive shadowing from a Stationary light in 4.2. In 4.3 (not out yet) there's approximate shadowing for translucency from Stationary lights, but it might not be accurate enough for that case.

If you can afford to use Cascading Shadow Maps on the directional light, that will shadow the grass properly. To enable CSM, set the DynamicShadowDistanceStationaryLight to 2k or so.

more ▼

answered Jul 08 '14 at 02:02 AM

avatar image

DanielW STAFF
1.9k 31 11 72

avatar image wARmAcH1n3 Jul 08 '14 at 02:43 PM

Ok I will wait hopefuly for 4.3, I want make the grass with low performance cost, thx for the info.

avatar image wARmAcH1n3 Jul 08 '14 at 07:01 PM

Hi Daniel, with Cascading Shadow Maps it works! The foliage is darker in shadows. Thx!

avatar image kurt_hectic Nov 10 '14 at 11:03 PM

"This is a missing feature, translucency does not receive shadowing from a Stationary light".

Ok, but Will it be repaired? When?

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same issue (screen attached)

I was able to fix it by clicking "Dynamic Indirect Lighting" inside Directional light. I turned ON and boom, it fixed the problem but later I turned it OFF and grass was still fixed :. So this switcher did something but I have no idea what happened. Is something broken? Anyone could give me clue what is happening? Should I keep "Dynamic Indirect Lighting" on or off? What if recalculation of the lightmaps will cause the problem again?

alt textalt text

more ▼

answered Oct 15 '14 at 09:22 PM

avatar image

kurt_hectic
66 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question