x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprints stop working, NO ERRORS, fixes itself after some time

My project was going great untill 2 days ago Blueprints started misbehaving. First it was my menu that for some reason stopped detecting mouse clicks after it worked fine for 3 weeks ....

Now another function with a for each loop stopped working after it worked fine. And spawn actor from class is not working too. JUST WDF??!???????!??????

I do not get errors and the [B]same[/B] code works in other projects.

I tried cloning, migrating, engine reinstall nothing fixes it, the problem must be in my project but I don't know how to fix it .

Product Version: Not Selected
Tags:
more ▼

asked Jul 06 '14 at 05:42 AM in Bug Reports

avatar image

Midnight640
46 7 10 14

avatar image Midnight640 Jul 06 '14 at 07:49 AM

Update: It seem that [load game from slot] > [cast to ***]> [get struct] > [break struct] does not work correctly because I replaced the struct with just normal values and now the problems are gone. (hope you can imagine the BP)(BP struct)

avatar image Ben Halliday STAFF Jul 09 '14 at 08:21 PM

Hey Midnight640,

Could you show us images of the Blueprints that were causing the issue? Any information that could help us reproduce the problem here would help us resolve the issue. Thanks!

avatar image Midnight640 Jul 10 '14 at 08:18 AM

I have no idea how to explain it one minute it was fine, next unexplained errors.... The weird thing was (in my memories) i think the [for each loop] was failing to cast but when I changed it to a loop with say 30 loops it worked great

Here are the screens I hope they shine some light.

alt text

alt text

(R click >open images in new tab to get full resolution)

avatar image Ben Halliday STAFF Aug 06 '14 at 08:56 PM

Hey Midnight640,

Sorry for the delay in response. Is this issue still occurring for you? Which version of the engine are you using now?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I was using 4.2.1 at the time , now I am @ 4.3.1 but I can't confirm that the problem is still here.

Is it possible that some sort of errors don't get resolved when I upgraded my project. My game began life on 4.0 and it went trough 4.0.1 > 4.0.2 > 4.1 >4.1.1 > 4.2> 4.2.1 and it got to a point where a lot of strange things started to happen (I have like 4 posts on AH with weird issues) and my project is BP only from a Blank project. I re-coded almost everything when 4.3 came out and now I am running with no major engine problems for now.

So I think this is something to maybe look at

Cheers!

more ▼

answered Aug 08 '14 at 06:54 PM

avatar image

Midnight640
46 7 10 14

avatar image Midnight640 Aug 08 '14 at 06:58 PM

PS: a major problem I had was that array of classes which I used to get an item from it and spawn it , crashed the shipping build .

Now in 4.3 It doesn't crash it but when i spawn a class that is IN that array the build crashes.

avatar image Ben Halliday STAFF Aug 08 '14 at 08:03 PM

It is certainly possible. There have been a lot of changes made between versions and we've been pushing out updates very quickly, so some conversion problems were inevitable. Sometimes it's not as obvious that there's a problem, though, so we can't always catch it. This should become less of a problem as the updates slow down and the engine becomes more feature stable.

I'm glad you got your project mostly problem free. For the array of classes crash, please attach your zipped crash logs. Does this happen with a new array, or just with an existing one in a project converted from an earlier build?

avatar image Midnight640 Aug 10 '14 at 06:41 PM

I have made a thread with explanation and pics+ files here if you want to take a look (Sean Gribbin said he replicated the problem) : https://answers.unrealengine.com/questions/72121/class-array-breaks-shipping-build-43.html

Also engine updates slowing means 1 major update per 2 months or 1 little update each month .

Thanks!

avatar image Ben Halliday STAFF Aug 11 '14 at 05:39 PM

I looked into the array issue you reported in that other thread, and it appears to have been fixed internally. I don't know whether it will make it into 4.4, but it should at least be fixed in 4.5. Thanks for reporting it!

We're looking at having a much more stable build in 4.5, and while I don't have any official word on it, I expect updates to slow to once every 2 or more months (not counting hotfixes). We're still very early in the life of UE4, but with the help of the community we've been able to fix many of the major bugs.

I'm going to mark this post as resolved for now, but if the same error reappears in your projects please feel free to reopen with as much information as you can provide. Thanks again!

avatar image Midnight640 Aug 11 '14 at 07:11 PM

Thanks for the reply I will report if the bug reappears and I hope I will be able to submit files since that seems to help a lot .

Cheers! UE4 rocks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question