x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do you debug a function in a blueprint function library?

I have several blueprint function libraries that I use for utility functions. I've noticed that when you set a break point and step into a blueprint library function it that the blueprint debugger stops providing watch information. The "Debug Filter" at the top sets itself to "No debug object selected" and nothing is available in the dropdown to select. Is this functionality supported by Unreal, can you watch values in a Blueprint library function using the Blueprint Debugger?

Product Version: Not Selected
Tags:
more ▼

asked Jul 06 '14 at 11:22 PM in Blueprint Scripting

avatar image

Jeremy McKeown
78 8 11 16

avatar image LALELiLU Nov 12 '14 at 07:11 PM

Did you have any luck getting this to work? I had it working, but now i can't debug library functions anymore, same symptoms as the ones you described.

avatar image morness Jan 21 '15 at 03:56 PM

I did a little more digging and it's absolutely broken (Blueprint Function Libraries) -- from a debugging standpoint, not a functional standpoint.

I had a complex math equation that I placed in it's own function, and while it lived in a B.F.L., it would not debug -- even when you step into it. It always loses debug focus. When I relocated the function to a Blueprint's Function, debugging works as normal. This is using 4.6.1.

Before alt text

After Stepping in alt text

Please fix this, Blueprint Function Libraries are important for global or sharable tech not tied to specific Blueprints. While there is an easy workaround by using something else, without debugging, I will avoid using this.

Basically what I'm doing now is creating a "singleton" blueprint in my scene and attaching functionality into a standard blueprint, but then I need objects to reference it, so it's not ideal.

before bfl.jpg (270.4 kB)
inside bfl.jpg (280.7 kB)
avatar image TorQueMoD Oct 15 '15 at 11:52 PM

I've been having similar issues where debug stops giving live feedback on what the blueprint is doing. Wonder when one of the Epic guys is going to comment.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi all,

We have a bug report open for this issue already (UE-18206) and we're hoping to resolve it with a large Blueprint Debugger upgrade. There is no timeframe for this currently, however I have added this post to the report and increased its community interest level. I'll track the bug report and post here when I see any change in its status.

more ▼

answered Nov 02 '15 at 07:06 PM

avatar image Jake1337 May 01 '17 at 06:22 AM

Hello! Correct me if I'm wrong but we're at 4.15.1 and this still has not been resolved. i.e. still no watch and basic debugging capabilities in blueprint function libraries aside from putting breakpoints without actually being able to track input/output values. Can anyone catch me up on this? It's such a shame since writing libraries is such a healthy powerful practice in any programming language.

avatar image gurudeva Oct 26 '17 at 03:08 AM

It's garbage.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've investigated this a little bit, and it seems that setting a breakpoint inside the library function won't let you fully debug anything. You need to break on the function call that would enter into the library function, then the debugging works as normal.

more ▼

answered Nov 12 '14 at 09:44 PM

avatar image

LALELiLU
141 3 5 57

avatar image morness Jan 20 '15 at 03:03 PM

This appears to be not working. I'm having the exact problem as the initial poster (months later with 4.6.1). I set a break point outside the function, and when I step into it, I lose context (and the debug filter is No debug object selected, and I can't pick one).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have that same problem ;( Someone found solution for this?

more ▼

answered Jun 08 '15 at 07:48 PM

avatar image

coldzik
1 1

avatar image alk3ovation Jun 10 '15 at 05:36 PM

I also just tried getting this to work in 4.7 and I still cannot view values in a function thats part of a BP function library. The context is lost. This makes writing complex functions in Blueprint Function Libraries impossible.

avatar image morness Jun 10 '15 at 06:04 PM

Okay so this bug has been around for about a year and it would be nice to hear from a developer on this issue now.

avatar image ElChipacabra Jul 06 '15 at 11:51 PM

I'm experiencing this issue as well and would appreciate at least a workaround that doesn't require completely rebuilding my function.

avatar image marceltoma Jul 13 '15 at 05:52 PM

I'm also experiencing this issue. version 4.7.6

avatar image Begounet Aug 12 '15 at 09:20 AM

4.8.3 have same problem. For now, the only workaround I have is to move the function in the actor using this function, debug, fix, and bring the fix to the Blueprint Library function. It can be very long to do it but when you don't have the choice... Hope it helped

avatar image Punitiate Oct 31 '15 at 09:18 AM

4.9.2 hitting this too. I wonder if this would have better luck in the bug report section, staff replies seem to be quicker there.

avatar image Jake1337 May 01 '17 at 06:22 AM

4.15.1 still the case...

avatar image Ch4nKyy Jun 14 '17 at 11:28 AM

Yep........

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question