Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android App crashes at launch (open gl error)


I recently moved my android app project on 4.16 version of Unreal.

Packaging is working fine but after I install the app on my Asus Zenfone 2, I can see the slapsh screen until it crashes.

I've tried to package as shipping and development, I correctly generated a keystore file, I've tried ETC 1 and Android (all) packaging. It doesn't work.

When I launch Android device monitor, it tells me " E/libEGL(3635): called unimplemented OpenGL ES API "

I don't know what to do ? Can someone help me ? Thank you.

Product Version: UE 4.16
more ▼

asked Jun 08 '17 at 09:52 AM in Packaging & Deployment

avatar image

26 5 8 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm having problems with my zenfone 2 too. Did you built unreal from source? What platform are you targeting (ARM or X86)? Does it work in the android X86 emulator? If it is X86 platform my game and tests shows its not working, they even crash in the android x86 emulator. If its ARM my game crashes after i do some 5 to 6 load new level calls on the Zenfone 2 (libhoudini crashes - Libhoudini is the ARM emulator).

Can you post your tombstone file and the monitor log? The tombstone file is in the /data/tombstones folder (i had to root my zenfone 2 to access this folder).

Has anyone successfully build an apk that uses the android x86 ABI with Unreal 4.16?

more ▼

answered Jun 13 '17 at 12:54 PM

avatar image

21 1 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question