x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

StaticMeshActor Collision in Blueprint doesn't run the OnComponentHit-event?

Hey, I want to create a Blueprint with a sphere, that detects it, when it collides with another object. So I added a normal sphere collision to the sphere and created a Blueprint with the sphere. The problem I have is, that when I let collide it with a normal Cube (StaticMeshActor), the Cube detects the collision and gets a physical impulse, but when I let it collide with another Blueprint, that has also a StaticMeshActor with collision, nothing happens. I also saw, that the OnComponentHit event never runs (also not, when it collides with the Cube). I dont use physics. Have I to use them? Or how can I do it without physics (because I dont want to use then, because I want to do some not-physical stuff afer a Hit with anoter actor)? Any ideas? :( Thanks for answers

Product Version: UE 4.16
Tags:
more ▼

asked Jun 08 '17 at 02:56 PM in Using UE4

avatar image

Niagarer
1 3 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I already set all all collisions to block all. I have the solution: The problem was, that I was setting the location of the Actor (in a Timeline) to simulate a flying object, but I did not check the checkbox "Sweep" at the set location node.

more ▼

answered Jun 12 '17 at 12:11 PM

avatar image

Niagarer
1 3 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Most likely the problem is that you have not set the correct collision settings. Try setting the collision volume of the other blueprint to BlockAll. That should fix it. To fine tune it you need to only use the correct channels for your blueprint, but that comes later.

HTH

more ▼

answered Jun 08 '17 at 10:47 PM

avatar image

NoobsDeSroobs
2.7k 107 35 180

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question