x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.16 Dynamic Shadow Artifacts

I have been seeing dynamic shadow artifacts on 4.16.0 and 4.16.1 using the packaged engine as well as built from source. To recreate, I have created a new level, added a directional light and a cube, set the cube to movable, and rotate the objects to create a self shadow on the cube. The issue is only present when the engine scalability settings are set to High, Epic, or Cinematic, but go away when set to Low or Medium. I have recreated this issue on separate machines with windows 7 and windows 10. Both machines have Nvidia Quadro hardware from different generations. I have updated to the latest Nvidia drivers. Has this issue been seen elsewhere? I have not found any bug submissions related at this point. Let me know if I can clarify anything.

Thanks, Ben

Product Version: UE 4.16
Tags:
cinematic.png (72.4 kB)
epic.png (71.4 kB)
high.png (70.8 kB)
medium.png (70.6 kB)
more ▼

asked Jun 08 '17 at 04:43 PM in Rendering

avatar image

ben.gaspar
1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello ben.gaspar

The lines that you see is appear when you rotate and adjust the light in "Z" axis. I got that lines between 70-90 degree angles. "Under Cascaded Shadow Maps" tab there is an option called "Num Dynamic Shadow Cascades". If you change the value from 3(default) to 1 or 4 you will see the difference. I think this is not a "bug" but something might needs improvement.

alt text

cascaded.jpg (195.7 kB)
more ▼

answered Jun 09 '17 at 04:06 PM

avatar image

KemalGunel89
126 2 5 16

avatar image ben.gaspar Jun 09 '17 at 04:26 PM

Thanks for the reply. I suspected this was some sort of regression, but verified that it was consistent with 4.15. I did some further investigations, and if I understand correctly this is only an issue with directional light, on a movable object, with large flat surfaces. That seems to explain when I didn't really notice until I created this artificial/simple scenario.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question