x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Visible gaps in meshes while walking.

I'm new with UE4 and i have this problem: https://youtu.be/BPT4gn4luqI I've tried to build everything and even packed it up.

Product Version: UE 4.16
Tags:
more ▼

asked Jun 10 '17 at 01:46 AM in Rendering

avatar image

Velu12
125 3 7 6

avatar image Velu12 Jun 10 '17 at 12:34 PM

Thanks everyone for help, I've learned a lot. But still can't get rid of it. Only KemalGunel89s method worked but it is not good for performance. If there is some way to render meshes in x distance from player, it should work. But I didn't find anything like that. increasing bounds scale for each mesh barley helps and provide FPS drops. Anyway thanks for help, I'll try to handle it somehow.

avatar image pr4wl Jun 10 '17 at 01:00 PM

Maybe you have too many individual meshes and it's overloading the culling methods? If so try combining some of the meshes. Ue4 has tools to combine meshes too. Just a shot in the dark.

avatar image Velu12 Jun 10 '17 at 01:34 PM

That is what it's looks like.

scene1.png (366.5 kB)
scene2.png (1.1 MB)
avatar image Velu12 Jun 10 '17 at 02:29 PM

Thanks everyone. I learned a lot! :)

avatar image Rgiz Jun 10 '17 at 02:56 PM

Velu12 in this screenshoot https://answers.unrealengine.com/storage/attachments/190353-scene2.png are the mesh overlapping?

Also, to test if the is the occlusion culling you can re-create the same level/rooms with only the Unreal BSP with OC on. Or you can use the same room, but add space between all mesh, just to test.

I think this is a overlapping mesh, cause looks the problem only happen where have a 2+ mesh intersection.

Let us know :)

avatar image Velu12 Jun 10 '17 at 06:02 PM

I merged everything and now it's ok

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Ok lets try something different. Save and backup your scene first for in case of any accident. And then open a notpad file then go to your level > select every object with CRTL+A > copy with CTRL+C > open notepad file and paste them with CTRL+V and save it. Now you are able to setup your scene in another level by reversing this process( copy from note pad to editor) if you dont change your directory. Now open a blank level > copy everything from the notepad file and paste in new level. Just wait i can take some time depends on level. If it's done without crashing or error check everything on the level for be sure. Next this step is a bit confusing if you are doing it for the first time. Select your wall static meshes and press right mouse button there should be an option "MERGE ACTORS" and click on it. And do the same settings as shown below. And click merge actors button. Choose the directory to save it and wait until its done. Now delete wall on your scene which you merged and bring the merged to your scene. Build lighting. And lets see what will happen. If you confuse to follow steps about merging actors go to this https://www.youtube.com/watch?v=xjx-bhCFIwc&feature=youtu.be

Goodluck...

alt text

merge.jpg (204.0 kB)
more ▼

answered Jun 10 '17 at 02:13 PM

avatar image

KemalGunel89
121 2 5 15

avatar image Velu12 Jun 10 '17 at 02:28 PM

Merged every wall and it worked :) Thank you very much!

avatar image KemalGunel89 Jun 10 '17 at 02:30 PM

You are very welcome. Hope your project goes well. Goodluck.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You may want to try increasing the "bounds scale" on your objects to keep them in view better.

You can learn a lot about UE4's culling methods here: http://timhobsonue4.snappages.com/culling-visibilityculling.htm Maybe something there will help you. Personally I've never run into that problem.

more ▼

answered Jun 10 '17 at 06:51 AM

avatar image

pr4wl
69 7 16 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Velu12

That is occlusion culling like "redbox" said. You can close it but i do not recommend for performance. Just disable it by clicking the checkbox. You can also check this link to understand how it works and how to avoid and adjust. Goodluck... https://www.youtube.com/watch?v=6MhsdwTW3SQ alt text

culling.jpg (247.6 kB)
more ▼

answered Jun 10 '17 at 09:12 AM

avatar image

KemalGunel89
121 2 5 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Can you try to disabling or lowering amount of motion blur on camera? Are you playing in editor or built.exe on desktop? If possible can your try too build it for desktop and test it again?

more ▼

answered Jun 10 '17 at 01:05 PM

avatar image

KemalGunel89
121 2 5 15

avatar image Velu12 Jun 10 '17 at 01:43 PM

I've tried both. YT video was made from exe file. Looks same in editor and in packaged project. alt text

package.png (264.6 kB)
avatar image Velu12 Jun 10 '17 at 01:50 PM

w/o blur it looks same.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is occlusion culling, and it will work in that way when you move camera very fast.

I'm not sure why this is so noticeable for you, but maybe environment is very modular.

more ▼

answered Jun 10 '17 at 04:29 AM

avatar image

redbox
4.3k 80 17 104

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question