x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Set Material's Opacity After it Has a Opacity Mask

Hi guys, I'm look for a method to set the opacity of my material after it has a opacity mask applied. As the mask just removes the areas which should be clear from the texture, I then want to set the whole material to have a opacity of 50% does anyone know of a way in which this can be achieved?

alt text

Thanks guys.

Product Version: UE 4.16
Tags:
example.png (437.8 kB)
more ▼

asked Jun 10 '17 at 03:55 PM in Using UE4

avatar image

CosmicMonkey
430 11 12 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hy Cosmic Monkey!

Between texure sample and opacity mask, add a clamp node and set the max value to .5

more ▼

answered Jun 10 '17 at 04:32 PM

avatar image

AZTECCO
1k 17 8 15

avatar image CosmicMonkey Jun 10 '17 at 04:40 PM

Thanks for the answer could you provide an example of this?

avatar image AZTECCO Jun 10 '17 at 04:57 PM

Sorry I m writing from phone..

You can follow these instructions.. 1 from the 4th channel of your texture sample, drag off and type clamp.

2 click the clamp node and in the details set the max value to .5

3 connect the return node to the opacity mask.

Let me know

avatar image CosmicMonkey Jun 10 '17 at 05:24 PM

I think I've done it how you specified, however this still hasn't gave my material 50% opacity its still at 100%

alt text

example.png (76.1 kB)
avatar image AZTECCO Jun 10 '17 at 05:50 PM

I'm so sorry ! My mistake!

You need opacity input to achieve this. To enable it choose translucent under blend mode of your material details. But you'll loose the op mask input.

Change that setting and movie the wire in o.o mask to opacity.. But the results depend on the alpha channel of your texture.

avatar image CosmicMonkey Jun 10 '17 at 06:03 PM

Perfect this has solved my issue. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question