x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Engine crashes when opening blueprints or running project

Hi Everyone,

I am having an issue where if I open an actor blueprint or if I attempt to run my project then the engine will crash. I can open HUD bps, and I can open materials, but if I open anything else then Unreal will crash.

At first it would crash when I loaded the engine but after I deleted the game map and created a new one it now only happens as I have described above. I deleted no assets and there was actually nothing on the map. I can think of no major changes I made to any of the blueprints or project settings.

Here is the last section of the error log:

[2017.06.10-21.13.14:741][ 0]LogLoad: (Engine Initialization) Total time: 34.18 seconds
[2017.06.10-21.13.14:741][ 0]LogLoad: (Engine Initialization) Total Blueprint compile time: 0.08 seconds
[2017.06.10-21.13.14:741][ 0]LogExternalProfiler: Found external profiler: VSPerf
[2017.06.10-21.13.14:741][ 0]LogExternalProfiler: Using external profiler: VSPerf
[2017.06.10-21.13.14:755][ 0]LogOcInput: OculusInput pre-init called
[2017.06.10-21.13.14:755][ 0]LogHMD: Starting GearVRController plugin
[2017.06.10-21.13.14:777][ 0]LogContentStreaming: Texture pool size now 1000 MB
[2017.06.10-21.13.14:841][ 1]LogAssetRegistry: Asset discovery search completed in 18.5711 seconds
[2017.06.10-21.13.14:843][ 1]LogCollectionManager: Rebuilt the object cache for 0 collections in 0.000001 seconds (found 0 objects)
[2017.06.10-21.13.14:843][ 1]LogCollectionManager: Fixed up redirectors for 0 collections in 0.000043 seconds (updated 0 objects)
[2017.06.10-21.13.18:860][456]LogSlate: Took 0.005598 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/Roboto-Light.ttf' (159K)
[2017.06.10-21.13.33:905][ 57]LogSlate: Took 0.000185 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/Roboto-Light.ttf' (159K)
[2017.06.10-21.13.33:959][ 57]LogMaterial: Missing cached shader map for material GuideRailMaterial, compiling.
[2017.06.10-21.13.34:096][ 57]LogMaterial: Missing cached shader map for material GuideRailMaterial, compiling.
[2017.06.10-21.13.34:110][ 57]LogMaterial: Missing cached shader map for material GuideRailMaterial, compiling.
[2017.06.10-21.13.34:152][ 57]LogMaterial: Missing cached shader map for material FMatExpressionPreview MaterialExpressionVectorParameter_0, compiling.
[2017.06.10-21.13.34:177][ 57]LogSlate: Took 0.007806 seconds to synchronously load lazily loaded font '../../../Engine/Content/Editor/Slate/Fonts/Roboto-BoldCondensed.ttf' (158K)
[2017.06.10-21.13.34:380][ 58]LogSlate: Took 0.007314 seconds to synchronously load lazily loaded font '../../../Engine/Content/Editor/Slate/Fonts/Roboto-Italic.ttf' (157K)
[2017.06.10-21.13.37:146][279]MaterialEditorStats: Info Base pass shader: 80 instructions
[2017.06.10-21.13.37:146][279]MaterialEditorStats: Info Vertex shader: 29 instructions
[2017.06.10-21.13.37:146][279]MaterialEditorStats: Info Texture samplers: 1/16
[2017.06.10-21.13.39:539][333]LogWindows: Windows GetLastError: The operation completed successfully. (0)
Thank you in advance for any help.

Product Version: UE 4.16
Tags:
more ▼

asked Jun 10 '17 at 09:24 PM in Blueprint Scripting

avatar image

Jippolatta
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok so for anyone else suffering from the same issue I found a very odd solution. If you can locate which blueprints are causing your game to crash (a lot of trial and error), open them in Notepad++ but don't change anything. I just opened my two broken blueprints and scrolled through them. After I closed them I booted up the editor and it worked like new. I have no idea why this worked but it did...

more ▼

answered Jun 16 '17 at 03:55 AM

avatar image

Jippolatta
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Im having the same problem and i know the blueprints that are causing it. But i tried your "solution" and it didnt work, UE crashes as soon as it loads the project. I really dont understand why your solution will work, you are not saving the file again and you are not doing anything with the file. Are you sure that you just didnt have luck and the problem just fixed by itself?

more ▼

answered Sep 28 '17 at 07:10 PM

avatar image

amstradcpcuser
31 4 9 13

avatar image Davision Nov 15 '18 at 12:33 PM

Has anyone found a solution here that makes sense?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question