x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] Migrating project from 4.15 to 4.16

Hi there guys and gals,

I recently migrated my project to 4.16. Since then VS 2017 throws an error when hot reloading:

 2>ERROR : UBT error : Failed to produce item: D:\unreal_projects\MyProject\Intermediate\Build\Win64\UE4Editor\DebugGame\UE4Editor-MyProject-3201-Win64-DebugGame.lib
 2>Total build time: 13.61 seconds (Local executor: 0.00 seconds)
 2>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command ""C:\Program Files\Epic Games\UE_4.16\Engine\Build\BatchFiles\Build.bat" MyProjectEditor Win64 DebugGame "D:\unreal_projects\MyProject\MyProject.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
 2>Done building project "MyProject.vcxproj" -- FAILED.

This occurs for all the attempts after the first compilation. Seems to be an issue with replacing the Win64-DebugGame.lib file to me. However this error doesn't seem to influence the hot reload capabilities of the editor. The hot realod still seems to succeed.

I start the launcher "as administrator", then I chose my project and start the editor. In the editor I start VS. So I'd assume everything is started with administrator privileges. To test if the windows UAC is causing the issue I disabled UAC completely but nothing changed.

Some time ago I read that having your project on another physical drive might cause issues. So I copied my project to my c drive, genereated the project files and gave that a try. Still, the problem is the same.

I'm out of ideas. Can anyone help?

Product Version: UE 4.16
Tags:
more ▼

asked Jun 11 '17 at 01:33 PM in Using UE4

avatar image

Edregol
169 13 15 26

avatar image Edregol Jun 20 '17 at 06:53 PM

I did some more research on this matter. Turns out this issue occurs even with a freshly created project. So this is not related to a migrated project but might have something to do with my system configuration, I guess. Still this issue first occured when updating the engine version from 4.15 to 4.16. Anyone got anything?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 01 '17 at 01:49 PM by Edregol for the following reason:

The question is answered, right answer was accepted


2 answers: sort voted first

I found my issue, I guess. I was messing around with the project settings a while ago since I had another issue which I can't remember right now. I was going through my solution properties (right click your solution -> properties) and compared them to a freshly generated project. Obviously I set the Startup Project Setting to "Multiple Startup Projects". After setting this to "Single Startup" everything worked fine again. Either this was the solution or the recent update to 4.16.2. Anyways problem does not occur anymore.

more ▼

answered Jul 01 '17 at 01:45 PM

avatar image

Edregol
169 13 15 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

"Please verify that you have sufficient rights to run this command."

such a message usually occurs when you have no write rights for a file most probably you have a source control and you are not connected to it, otherwise somebody else might have checked that file for himself therefore it doesn't allow you to edit it till he submit changes or revert.

if you don't have a source control, check if you can manually edit this file (notepad++ or anything) does it save?

more ▼

answered Jun 20 '17 at 07:54 PM

avatar image

Arty-McLabin
893 20 42 62

avatar image Edregol Jun 23 '17 at 05:52 PM

No source control yet. And I can open that file just fine. I do see some xml datastructure.

avatar image Arty-McLabin Jun 24 '17 at 09:41 AM

opening is not the deal, try to edit the file. there is a difference between reading and writing files.

avatar image Edregol Jun 25 '17 at 07:08 PM

To clarify things. VS is complaining that it can not crate the file UE4Editor-MyProject-3201-Win64-DebugGame.lib, right? I tried to open the "MyProject.vcxproj" previously. So this didn't help at all. The *.lib file does not get created. So it seems to be an access issue after all.

avatar image Edregol Jul 01 '17 at 01:46 PM

thanks for you help arty, I guess I found my problem. If you're interested have a look at the answer I wrote.

avatar image Arty-McLabin Jul 01 '17 at 03:33 PM

np, i'm glad you have managed it :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question