x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Text render is black when placed in shadow

alt textHello. I went through Blueprint video tutorials on official Unreal youtube channel. One of the things was to place text tips by Text Render component. It worked fine and text was pretty bright, but later I experimented with lighting settings and it somehow broke Text Render, and now all the text in shadow is competely black. I'm sure it worked fine before, but I think I returned all the settings as it were (even pressed Restore settings), but it still doesn't work as it should, even on completely new project. What could gone wrong? (P.S. Also I noticed my shadows are too black, comparing with video)

Product Version: UE 4.16
Tags:
testrender.png (415.0 kB)
more ▼

asked Jun 11 '17 at 07:32 PM in Rendering

avatar image

Max Pio
18 4 9

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

It is black, because there is no light on it. Either, give the material an emissive color, make the material unlit, or light it in the level.

To change the material to be unlit, emit the same color. Optionally on your own, you could change the material to be actually unlit, but for now the below will help you learn.

Go to the details panel of your Text Render. Find the material. Click the magnifying glass to find the material that it uses.

Your content browser should select the material, as seen below. Then you must make a copy of this material in your game's material folder,.

Open up your copy of the material, and add a pin from Vertex Color, to Emissive Color.

Save the material, then go back to your Text Render, and change the material to be your new one.

more ▼

answered Jun 11 '17 at 10:35 PM

avatar image

BenVlodgi
2k 37 17 51

avatar image Max Pio Jun 11 '17 at 10:43 PM

Thank you for detailed instruction. It make sense, that without external (or internal) lighting it should be unlit. I'll try it. I also decided to reinstall Unreal Engine to get it back to default state, just for the sake of it.

I think it has something to do with overall lighting, because I believe shadows were not so black before. Now I see, that in the tutorial this text also isn't bright at all. But shadows also aren't so dark as mine. https://youtu.be/EmvekeKk-0o?list=PLZlv_N0_O1gY35ezlSQn1sWOGfh4C7ewO&t=918

Is it skylight? Because I use default map, and I didn't see, that teacher added it in the beginning of creating level.

avatar image BenVlodgi Jun 11 '17 at 10:55 PM

The lighting settings you have are probably preview and are unreliable. Try building production lighting to see how it will show up in final game.

avatar image Max Pio Jun 11 '17 at 11:54 PM

I reinstalled UE and checked production light and it's still as dark. But - I checked tutorial again and noticed, that after teacher created default map - skylight is already there in World outliner - https://youtu.be/_zoyaVdqHQ8?list=PLZlv_N0_O1gY35ezlSQn1sWOGfh4C7ewO&t=125

I have no idea why it isn't default for me, probably difference in versions of UE. Now I see, that my idea to make it work even without realistic lighting (with skylight) make no sense, but I suppose I'm too stubborn =) Thanks again for your answers.

avatar image BenVlodgi Jun 14 '17 at 04:17 AM

If the solution worked, you should mark this as the correct answer. :)

(comments are locked)
10|2000 characters needed characters left

Try to add skylight on your scene for breaking shadow contrast and check your text renderer material setting. Can you change it to unlit?

more ▼

answered Jun 11 '17 at 07:38 PM

avatar image

KemalGunel89
111 2 5 15

avatar image Max Pio Jun 11 '17 at 09:28 PM

I read somthing about that, but I'm newbie, so I don't know how to do it yet. Besides, in this video there were no skylight, so I'm interested how to fix this issue without skylight. But thank you for your answer.

avatar image Max Pio Jun 11 '17 at 09:46 PM

Sorry, I don't know where to find text renderer material settings.

avatar image Max Pio Jun 12 '17 at 12:09 AM

Yes, it was skylight.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question