x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging error with Nativization

Hey guys, I've tried everything I can possibly think of from reinstalling Visual Studio (and ensuring I had all the required add-ons) to reinstalling every single windows SDK and combing through the output log of the packaging process (though most of it doesn't mean terribly much to me). I can't find anything helpful in it, but I still get an error and it fails to package properly.

The thing is, that it does package properly when nativization is disabled, even though I have a combination of code classes and blueprints. I'd really like to have nativization on though performance reasons, so if anyone can please help me I'd very much appreciate it. I'm attaching the output log.link text

Product Version: UE 4.16
Tags:
cook.txt (516.4 kB)
more ▼

asked Jun 16 '17 at 06:19 AM in Packaging & Deployment

avatar image

Travinator98
10 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can try to exclude some Blueprints from being nativized. Your log even tells you at the end which Blueprint seems to be effected. Just exclude it and include all other Blueprints. If you found out that this 1 specific Blueprint is killing your performance, come back! <3

more ▼

answered Jun 16 '17 at 06:40 AM

avatar image

Ninjin
4.2k 88 38 152

avatar image Travinator98 Jun 16 '17 at 10:03 PM

Thank you for such a quick response. I set the nativization to exclusive and unchecked nativize on my charater blueprint (the one I thought was causing the issue), and still got the exact same error, so I hunted through every single blueprint class I could find and did the same, noticing that all my BPIs were nativized (does that cause an issue?). Once I had done that, the packaging process was able to proceed a little further, but still failed with this new log. Any ideas?link text

cook.txt (506.2 kB)
avatar image Ninjin Jun 16 '17 at 10:24 PM

Your character BP? From your first log I was assuming this one:

BP_BaseDoorInteraction__pf4074830031.h(20) : Error: ExposeOnSpawn - Property cannot be exposed

That's from your first log. Can you try only exluding this one?

avatar image Travinator98 Jun 16 '17 at 11:35 PM

I tried excluding but got another package failed error. I was able to compile it with nativization on and nothing selected to nativize again, but if it's possible I'd really like to figure out what's keeping it from nativizing just for preformance's sake like I said. Thank you again for your help, even if it can't be figured out.link text Here's the new editor log.

cook.txt (498.3 kB)
avatar image Ninjin Jun 17 '17 at 12:11 AM

First, you don't have to include the whole output log.

UATHelper: Packaging (Windows (64-bit)): Project.Cook: COOK COMMAND COMPLETED UATHelper: Packaging (Windows (64-bit)): Project.Build: BUILD COMMAND STARTED

That's where you hit the package button. Everything above is you clicking around in the editor ^^.

From there you can usually look for your own files (trust me, it's that easy, I'm just a normal human and there is a lot of stuff there that my eyes just skip, because I have no idea what it means) Anyway, while skipping some egypt language after BUILD COMMAND STARTED you might recognize your own Blueprint:

4.16/Intermediate/Plugins/WindowsNoEditor/NativizedAssets/Source/NativizedAssets/Public/ThirdPersonCharacter__pf2222656877.h(374) : Error: Unrecognized type 'ICombatModeInterface_C' (in expression TScriptInterface) - type must be a UCLASS

See, it's saying ThirdPersonCharacter is giving errors. You could check out what it means. Btw, are you using C++?

Besides, it's not that rare that you are using functions that can't be nativitzed. It's out of experimental state, but you can find some functions that still can't be nativized.

Furthermore, if you are talking about performance, you should back up your words with some profiler log. Not to be negative, but nativization is not the magic button that makes your game run smooth. And if you press that button, that doesn't mean you are 1 step ahead of other game devs <3.

avatar image Travinator98 Jun 17 '17 at 12:21 AM

Oh lol my bad. I just didn't want to leave out anything important and since I didn't know what most of it meant, I was afraid to leave it out. I am using a combination of C++ classes and blueprint classes. I'll look at the asset you referenced, but all in all, the performance of the game isn't suffering horribly, I was just trying to squeeze every frame out of it that I could. So in the end I can probably get away with that one not being nativized. Thank you again for your help :)

avatar image Ninjin Jun 17 '17 at 12:34 AM

If something here was helpful or you solved your problem with 1 of my answers, it would be nice if you mark the correct one as an answer to your question, so others can see what's useful ;P. And if you actually find out the exact reason why it didn't nativize your blueprint, feel free to add it at a later time! <3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question