x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Background Blur renders black on Android

Any news on fix for that? Issue UE-39515 is there since 4.15 version.

Steps to Reproduce:

-Create a UMG Widget that uses the blur component

-Add the widget to your viewport via the level BP

-Pie, observe that the blur works

-LaunchOn or package, install, and open it on an android device

Product Version: UE 4.16
Tags:
more ▼

asked Jun 18 '17 at 09:39 PM in Rendering

avatar image

Fairlightish
23 4 6 8

avatar image aspartamed Sep 05 '17 at 02:41 PM

Anyone have any work around since the bug exists for version 4.15, 4.16, 4.17 and is scheduled to be fixed in 4.18?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I already saw similar questions and I also face this problem in my mobile project.

I think its because UMG blur not supported on mobile devices. Maybe it will work on some hi-end/metal render, but I not checked. So in my project I just disabled this and use simple mid-black translucent background.

more ▼

answered Jun 19 '17 at 09:17 AM

avatar image

redbox
4.2k 79 16 101

avatar image Fairlightish Jun 19 '17 at 05:13 PM

It's a confirmed bug for over 6 months https://issues.unrealengine.com/issue/UE-39515

(comments are locked)
10|2000 characters needed characters left

SBackground.cpp

 #if PLATFORM_ANDROID
 // This feature has not been tested on es2 and will likely not work so we force low quality fallback mode
 static int32 bForceLowQualityBrushFallback = 1;
 #else
 static int32 bForceLowQualityBrushFallback = 0;
 #endif    

If you want to enable background blur on android device(vulkan device?), add option to DefaultDeviceProfiels.ini or use commandline.

 [Android DeviceProfile]
 +CVars=Slate.ForceBackgroundBlurLowQualityOverride=0
more ▼

answered Jan 24 '18 at 09:55 AM

avatar image

ttmayrin
11 1 1

avatar image Roi Danton Feb 03 '19 at 12:26 PM

A test doing it on Nexus 5x failed. Either it was wrong to put the file DefaultDeviceProfiles.ini in myproject/config or it is not supported on older devices.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question