x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Key Structure" reroute nodes cause compilation problems

reroute nodes of "Key Structure" cause the blueprint to get "dirty; need compilation" right after you compile it. no matter how many times.

alt text

i have noticed that only with Jesus Christ help after 3 weeks of compilation hell (by rolling back with other purpose).

this was the solution...

alt text

extremely stealthy and annoying bug.

Product Version: UE 4.16
Tags:
more ▼

asked Jun 19 '17 at 03:35 PM in Bug Reports

avatar image

Arty-McLabin
868 19 41 61

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Arty-McLabin,

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-46223

Make it a great day

more ▼

answered Jun 19 '17 at 07:42 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image joel.m3c Apr 30 '18 at 07:00 PM

Hello!

This bug is still there.

Having a reroute node on a Key Structure wire prevents the Blueprint to compile. Once removed, I have to compile twice in a row to finally get my blueprint good to go.

Tested in 4.19.1.

alt text

unrealbug.png (204.0 kB)
avatar image Everynone Apr 30 '18 at 08:03 PM

I run into this last week too when comparing mouse buttons even though no reroute pins were used.

avatar image Arty-McLabin Apr 30 '18 at 11:30 PM
avatar image Rudy Q ♦♦ STAFF May 24 '18 at 06:51 PM

Hello,

I ran a few quick tests and I was unable to reproduce this issue on our end. We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image joel.m3c May 24 '18 at 07:05 PM

Just tested again in an empty project. This is a screenshot from the level blueprint.

Plug in the disconnected wire and compiling is going to fail.

I reported the issue a while ago, but nobody created an entry for this bug.

Cheers.

[1]: /storage/temp/242083-unrealbug.png

unrealbug.png (84.9 kB)
avatar image Alex O ♦♦ STAFF May 24 '18 at 07:56 PM

Hello All,

I was able to reproduce this in 4.19 (Rudy was using original repro steps that did not involve == node)

However, I was unable to reproduce in 4.20!

I'll be getting notifications on this thread - so let me know here if there are still any issues after checking for yourself in the 4.20 preview (when it launches)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question