x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmaps stuck displaying Lowest Quality

With my scenes I've noticed that after the amount of lightmaps hits a certain point, the streaming/mipmap system seems to stop working for lightmaps (as well as textures but they are easily solved by stopping them from streaming)

Since I am using Unreal for Arch Viz, My scenes are normally pretty high quality with lots of large uncompressed lightmaps to get the most quality as the end spec of the project is high and realism is the most important thing. I have had this problem since i've started really on version 4.6 .Problem is after a certain level of detail the lightmaps default to their lowest quality no matter what distance you are away like this:

alt text http://i.imgur.com/FxCKFVT.jpg

The only solution I have found for this is to go into every single lightmap one by one and setting them to generate no mipmaps, like so

alt text http://i.imgur.com/rDySY32.png

when I do it for all lightmaps its finally back to the correct quality like this:

alt text http://i.imgur.com/XEi6h2E.jpg

While this solution works in the short term, it is incredibly time consuming when you have over 1500 to do as it takes literal hours to do.

What I'm wondering is what might be causing this problem and how can I fix it?

It would be incredibly helpful as it would save me hours of time each and every time I rebake. I would also be happy with a solution to turn off mipmap for lightmaps faster as well, i've tried turning off streaming project wide which i think also worked but it had a huge hit on the FPS where as just the lightmaps didn't really effect it.

Thanks for the help

Product Version: UE 4.16
Tags:
more ▼

asked Jun 20 '17 at 11:29 AM in Rendering

avatar image

CactusFantastico
80 10 21 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Right I found the answer. I forgot I had put a node to disable all screen messages a while ago and didn't notice I was way over the default texture streaming pool size. Once I upped it with console commands all the lightmaps snapped back into their correct Mip.

Also for fun do you want to know how far over my texture steaming pool size I was? 5gb.

5 Whole gig over the default haha

more ▼

answered Jun 21 '17 at 03:55 PM

avatar image

CactusFantastico
80 10 21 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This should be configurable with device profile.

In editor open Window > Developer Tools > Device Profiles. There you will find settings for every platform. In case your platform is Windows, press button on TextureLODGroup settings next to it, find Lightmap and Shadowmap there and set its mip gen settings to NoMipmaps.

Then press Save As Default on top of 1st window.

Hope it helps.

more ▼

answered Jun 20 '17 at 03:11 PM

avatar image

redbox
4.3k 81 19 104

avatar image CactusFantastico Jun 21 '17 at 03:53 PM

Hmm I'm not sure if this helped, New lightmaps didn't default to no Mipmap but it didn't visually make a difference but then again I found out what the problem was anyway but thanks anyway

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question