x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can you automatically include referenced headers?

The basic FPS tutorial doesn't use any new #includes in the header files at all, but without trawling the engine source I can't find what I need to include in order for it to actually compile. How is it supposed to be done? Is it by editing the build c# file? I'm using VS 2017, and UE 4.16.

Product Version: UE 4.16
Tags:
more ▼

asked Jun 20 '17 at 01:33 PM in C++ Programming

avatar image

Admiral Harvard
1 2 3

avatar image ZeroParadigm Jun 20 '17 at 05:09 PM

Hi @Admiral Harvard , did you run the Setup.bat and GenerateProjectFiles.bat before launching Visual Studio? You might need to add the -2017 parameter when running the GenerateProjectFiles

Another page may help also https://answers.unrealengine.com/questions/596678/generateprojectfilesbat-2017-vs-2017-error.html

avatar image Admiral Harvard Jun 20 '17 at 06:22 PM

I'm not building the engine from sources, I'm just using the release version

avatar image ZeroParadigm Jun 20 '17 at 09:32 PM

If you can provide the compile errors you are experiencing we can help diagnose the errors if needed.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

The problem mysteriously resolved itself; I think it wasn't including the project header, which seems to remove the need for the manual includes. The solution was to recreate the C++ files, checking that the #include ProjectName.h is in the relevant headers of the files

more ▼

answered Jun 20 '17 at 10:04 PM

avatar image

Admiral Harvard
1 2 3

(comments are locked)
10|2000 characters needed characters left

it's less of a UE4 question and more of a general C++ one.

it is basically impossible, but it is not hard to do manually anyway.

it should be a matter of half minute to troubleshoot and google up what headers do you need to include according to the compilation error you have. also it doesn't happen too often.

more ▼

answered Jun 20 '17 at 08:09 PM

avatar image

Arty-McLabin
858 19 41 60

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question