Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing Texture on Foliage

Hey all,

Having some trouble with the foliage brush and a specific mesh when running a stand alone game or recording a movie out of matinee. When manually placed, not using foliage, the mesh appears properly with its material. When placed using a foliage brush it loses its material.

Everything is fine in-editor and PIE only when recording out a movie or playing a standalone game o they disappear. This happens with the mesh even in new maps but only with this certain mesh, the mushroom from the stylized demo, not others.

Thoughts? I really don't want to have to place these manually.

Product Version: Not Selected
more ▼

asked Jul 07 '14 at 03:18 PM in Everything Else

avatar image

270 26 41 164

avatar image Devatsu Jul 07 '17 at 03:11 PM

Not meaning to necro this, but this has happened to me recently aswell, and your workaround fixed it like a charm; did anyone figure out a way to prevent this from happening?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok, so opening up the problematic materials and nudging a node and resaving seems to have fixed the problem.

Weird. I remember this happening in UDK sometimes but I didn't think it would carry over to UE4.

more ▼

answered Jul 07 '14 at 04:32 PM

avatar image

270 26 41 164

avatar image clt2488 May 31 '15 at 09:27 PM

This just happened to me too, and your fix of making a trivial change and re-saving the materials worked. Thanks!

This feels like a UE4 bug. FWIW, Epic, these assets were migrated from another project; maybe that's related?

avatar image Tymax Sep 23 '15 at 09:55 PM

I can confirm this problem still exists in 4.9.

To reproduce: 1. Migrate custom content into your project via Epic Launcher (for example the KiteDemo project) 2. (step to confirm) Use a personal directory structure, sodrag'n'drop Materials/Meshes with "copy here" 3. Add meshes to the foliage tool and draw them in the editor

Everything looks nice in the editor, but running the actual game will cause missing textures (and sometimes even messed up meshes).

Fix as mentioned: Change something trivial inside one of the migrated materials and save. All migrated materials/meshes are now displayed correctly in the actual game.

avatar image Pseudocorpus Mar 21 '16 at 04:52 PM

Very odd fix but worked like a charm. Thanks!

avatar image Bill_León Jul 27 '18 at 11:07 AM

V 4.20 also have this bug. Also fixed with that. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

CONFIRMED FIXED ON 4.20 WITH RE-SAVING THE MATERIAL!!! I was using InfinityBladeGrassLands grass!

more ▼

answered Aug 21 '18 at 01:20 AM

avatar image

13 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question