x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How do I compile lightmass?

Everytime I press Build in my Unreal engine editor an error pops up wich say : Lighting build failed. Swarm failed to kick off. Compile Lightmass. Now I dont have any clue how I can compile the lightmass. Can you help me?

Product Version: UE 4.16
Tags:
more ▼

asked Jun 26 '17 at 01:13 PM in Rendering

avatar image

Benzproduction
11 1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first
more ▼

answered Jun 26 '17 at 02:36 PM

avatar image

Nachtmahr
6.9k 143 26 172

avatar image Daciansolgen May 19 '18 at 10:33 PM

i have same problem :( nothing works.

avatar image yoko3d Oct 24 '18 at 10:30 PM
avatar image granger-daydream May 17 '19 at 06:04 PM

Thanks. That worked for me too in 4.22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If anyone still needs this... I was building UE 4.22 from source in Visual Studio and got this problem.

This answer probably doesn't pertain to the launcher version of UE.

PLEASE NOTE: I have no clue whether what I did was a good idea--just that it solved this problem at the time.

The solution was to build the UnrealLightmass project in Visual Studio. To do that, I couldn't just right click UnrealLightmass and build. (I got an invalid configuration for Win32 message.)

First, r-click UnrealLightmass > Properties. Click upper right button to go to the Configuration Manager. (Or just get to Configuration Manager any way you like).

In the list, find UnrealLightmass.

Change the configuration from 'Invalid' to 'Development_Program' (random guess) and Platform x64.

Then, r-click UnrealLightmass and builld.

Relaunch the engine for good measure.

This allowed the Swarm Agent to work in the Editor. But, again, I have no idea if my build configuration makes any sense.

more ▼

answered Apr 22 '19 at 07:20 PM

avatar image

melsovereign
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question