x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

HELP! The project could not be compiled. Would you like to open it in Visual Studio

Please help! I'm new to UE4, I downloaded a course from Udemy and followed the download instructions. I have visual studios 2017 with the windows 10 and 8.1 SDKs (86 & 64) and UE4 4.13.3.When I try to make a template in C++ blank I keep getting this error. It does not occur when I use a regular blueprint. I've tried uninstalling and downloading both programs and keep receiving the same error message.

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files (x86)/Epic Games/4.14/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject2 Development Win64 -project="C:/Users/Dustin/Documents/Unreal Projects/MyProject2/MyProject2.uproject" -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE @progress push 5% Parsing headers for MyProject2Editor Running UnrealHeaderTool "C:\Users\Dustin\Documents\Unreal Projects\MyProject2\MyProject2.uproject" "C:\Users\Dustin\Documents\Unreal Projects\MyProject2\Intermediate\Build\Win64\MyProject2Editor\Development\MyProject2Editor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed Reflection code generated for MyProject2Editor in 3.9915965 seconds @progress pop Performing 7 actions (2 in parallel) [2/7] Resource PCLaunch.rc PCH.MyProject2.h.cpp [3/7] Resource ModuleVersionResource.rc.inl C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\INCLUDE\crtdefs.h(10): fatal error C1083: Cannot open include file: 'corecrt.h': No such file or directory ERROR: UBT ERROR: Failed to produce item: C:\Users\Dustin\Documents\Unreal Projects\MyProject2\Binaries\Win64\UE4Editor-MyProject2.dll Total build time: 30.66 seconds

Product Version: UE 4.14
Tags:
more ▼

asked Jun 30 '17 at 12:28 AM in Installation & Setup

avatar image

Darthboogers
6 1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
  • open your visual studio installer, choose Modify, choose Individual Components, choose Unreal Engine Installer under "Games and Graphics" section. Install this component should solve your problems.

more ▼

answered Aug 12 '17 at 02:04 AM

avatar image

JackInReal
16 2

avatar image Taberu Aug 26 '18 at 01:58 PM

Thanks, updating VS and UE4 layer helped me with that one!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question