Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AI Navigation Works on Development Build but Not Shipping

Enemies doesn't start walking after spawning when running on a build packaged with the Shipping configuration. It works perfectly however when running the game from the editor or on a packaged Development build.

What can be the issue here? What are we missing in the Shipping build vs. Development build? Can it be something entirely else not relating to navmeshes?

I've tried these options without any luck:

-Force Rebuild on Load

-Dynamic Runtime Generation

-Placing the navmesh in either the persistent level or the sublevel and also placing it in both levels

-Deleting all navmeshes and recast and placing them in the level again

Product Version: UE 4.16
more ▼

asked Jun 30 '17 at 11:27 AM in Packaging & Deployment

avatar image

91 4 9 13

avatar image dave_sullivan Oct 17 '17 at 06:35 PM

I'm hitting a similar issue, were you ever able to find a solution?

avatar image rogeriooo Oct 21 '17 at 03:21 AM

I'm with a similar issue as well, was able to pinpoint to the behavior tree key value that by some reason does not get set in the packaged build. Mine does not work on shipping and development. I can find a work around for that with class calls in my case, will try later.

avatar image rogeriooo Oct 21 '17 at 02:36 PM

Alright, the issue was at one of the blackboard values not being set in the packaged build. I simply added a class call and got the value in the BTT/BTS when spawned, set it there and it worked fine. Now mine works in development/shipping settings as well. After further investigation, any "get value" from the blackboard does not work in build/ship, so consider changing the approach to these values.

avatar image dave_sullivan Oct 21 '17 at 03:57 PM

Interesting, thanks! So blackboards don't work in production? I find that hard to believe. By any chance is it a multiplayer game and you're trying to access the blackboard on client? I think that's part of my problem or at least has been where I've been finding issues. Honestly I'm really not sure what a blackboard is good for that a dictionary/hashmap on the controller couldn't have done. Has overcomplicated my project's AI. I guess blackboards handle events and stuff too, which a map wouldn't necessarily, so maybe that's the big sell. Still... In any case, thank you for your reply!

avatar image rogeriooo Oct 21 '17 at 04:03 PM

No problem! Blackboards does works, just the "get blackboard value as..." apparently does not works. A good tutorial for AIs is this one: https://www.pluralsight.com/courses/introduction-ai-navigation-systems-unreal-engine-2205 There are others too, but this one gave me the basic understanding to expand it as I needed.

avatar image runF0rrestRun Mar 20 '18 at 07:04 PM

Same problem, BB value came back null/none on packing. working perfectly fine in editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We've been reworking a lot and cleaning out some stuff during the project and now it suddenly works. Unfortunately we haven't been able to pinpoint what it was that actually caused the issue. We've updated to 4.18 and that might also have contributed to getting it working again.

more ▼

answered Mar 21 '18 at 12:39 AM

avatar image

91 4 9 13

avatar image slaas Aug 29 '18 at 07:49 AM

For us, ProjectPointToNavigation does not work in a packaged build. Did you, by any chance, use that one?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question