x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Day Night Cycle, landscape much brighter during night than day

Hi there. I've started a new project added in a landscape and setup a basic daynight cycle. But as the title says, the brightness of the landscape is way brighter at night than at day. The day night cycle is using a timeline in the level blueprint, then setting the rotation accordingly and updating the sky.

https://www.youtube.com/watch?v=IQTzTIMyggA&feature=youtu.be here is a video showing what happens.

How can I make the night darker while still keeping the brightness of day? Any help would be appreciated. Thanks in advance.

Update: I have been using this tutorial: https://wiki.unrealengine.com/Tutorial:_Time_of_Day , but no luck. I've set the inensity to 0 at night and also turned it to be invisible. I've unchecked the two sided lighting tick box for the landscape and it still is really bright at night. Could it be my landscape material or the skybox?

Product Version: UE 4.16
Tags:
more ▼

asked Jul 01 '17 at 01:50 AM in Blueprint Scripting

avatar image

Brylos
40 8 17 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi i had the same problem. To fix it you have to add a PostProcessVolume and set under Lens>Auto Expose> the MinBrightness to something like 0.995 and the Max Brightness to 2.99 . I hope thats helpfull :)

more ▼

answered Jul 01 '17 at 04:25 PM

avatar image

Medivis
26 2 2

avatar image Brylos Aug 01 '17 at 11:20 AM

Sorry it took me insanely long to respond lol. Forgot I even posted this but thank you! Your solution worked :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I made my Day-Night-Cycle in Matinee and reduced the Directional-Light´s Intensity at Night to 0, because the Sunlight shines through the Landscape^^

more ▼

answered Jul 01 '17 at 02:04 AM

avatar image

Killerzwerg
1 1 3 4

avatar image Brylos Jul 01 '17 at 02:17 AM

I tried that using the level blueprint but it didn't change anything. Bare in mind that the intensity is changing, it's just that even if it is at 0, the landscape still looks very bright. Do you think setting it up in the matinee would make it work if it doesn't work in the level blueprint?

avatar image Killerzwerg Jul 01 '17 at 02:30 AM

Sorry for my mistake, I have looked in my matinee now, it´s not exactly at 0, it´s on 0.0001, try this^^

avatar image Brylos Jul 01 '17 at 02:34 AM

I tried that and it still looks the same. Maybe it has to do with my landscape material?

avatar image Killerzwerg Jul 01 '17 at 11:32 AM

I don´t think so, the problem is, the Light can shine through the landscape (makes no different how the material is set up).

I have never made a Day-Night-Cycle in BP, so I don´t know what´s the difference, but I have sent this question to a friend who made his Day-Night-Cycle in BP^^

I thought there is no difference between BP and Matinee...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question