x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 beginner seeing weird bounce behavior from Sphere bouncing indefinitely on simple static mesh

Hello,

I'm barely starting to learn UE4 and I've been following a tutorial online where I have to create a ball and enable physics on it. Once I did that and started simulating the game, I noticed the ball keeps bouncing in a weird way on the static mesh floor from the default map. I duplicated the ball and added a cube mesh and that one doesn't bounce in the same way.

https://youtu.be/D1JCE-J09EE

I compared both floor meshes and they have the same settings. I searched the Answerhub and online and could not find why this is occurring.

Why is the leftmost ball doing this?

Product Version: UE 4.16
Tags:
more ▼

asked Jul 02 '17 at 09:10 PM in Everything Else

avatar image

jfchevrette
1 2 3 4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi,

I see that you are using UE 4.16. Your problem looks like a common bug and I hope it will be fixed in the next release. For now try to turn off PCM for PhysX:

Project Settings > Physics > Simulation > Enable PCM [click to turn off]

You may need to click "Show Advanced" arrow to change Enable PCM value.

In 4.16 we enabled PCM for PhysX (their new contact generation algorithm). While this gives great performance improvements, we are still working with them to fix some final stability and jitter issues. As such we recommend turning PCM off if you experience jitter in your simulation. (Project Settings > Physics > Simulation > Enable PCM)

Source: https://forums.unrealengine.com/showthread.php?145720-4-16-Released!&p=730229&viewfull=1#post730229

more ▼

answered Jul 24 '17 at 01:25 PM

avatar image

muppet1906
6 2

avatar image Kuldeep Thakre Feb 06 '18 at 03:07 PM

This is something I was searching for a month now, and finally found it here.Thanks for the solution by the way.

avatar image Kuldeep Thakre Feb 06 '18 at 03:08 PM

But does turning off PCM, have any drawbacks?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question