x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

<p>Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed.</p>

Blender Export : Skeletal Mesh Problems (Bounds & Blend Shapes)

Hey there... I have two problems when I try to import my animated Blender-Character into UE4:

  1. My Bounding Box ("Bounds") is way to big

alt text

  1. My Blend Shapes (/Morph Targets) make the model morph into a weird pose. They deform the right portion of the body, but I think in addition the mesh deforms into an upright walk pose, which should be handled by the bones-animation, not the Blend Shapes.

alt text

If it helps, here are my Export/Import-Settings:

alt text

Help would be greatly appreciated.

Product Version: Not Selected
Tags:
boundingbox.jpg (30.2 kB)
blendshapes.jpg (34.3 kB)
more ▼

asked Jul 07 '14 at 10:23 PM in Using UE4

avatar image

Pseudocorpus
421 37 47 143

avatar image Pseudocorpus Jul 12 '14 at 04:03 PM

So no one encountered this problems yet?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi, this is late but I think I figured out the morph problem!

In blender, if the pose the character has upon export is different from whatever Unreal Engine decides is the default, all the morph targets/blend targets will include that pose! To fix, just set the Blender pose to whatever UE4 thinks is the default, save and export to FBX, and the morph targets will look normal.

(To check for this bug, open the skeletal mesh file in UE4 and apply several morph targets; if the model stretches further and further with each morph, this is the problem).

more ▼

answered Aug 13 '14 at 11:05 PM

avatar image

AdrenalineHigh
36 4 6 9

avatar image Pseudocorpus Aug 13 '14 at 11:39 PM

Hey Adrenaline... thanks for your answer.

First to the bounding box Problem. It was a scale issue I guess. Once I scaled up my mesh AND applied Scale in Blender, the Physics asset and therefore the bounding box worked correctly. Now I have to re-do all my animations. This is gonna take long, but if that is the price... ok. So remember to APPLY (Ctrl + A) all transformations to Mesh and Armature before animating.

After that and with the export/import-settings below the Morph Target Problem seems to be gone. But if it ever occurs again, I am going to try your method. Thanks again!

alt text

avatar image AdrenalineHigh Aug 13 '14 at 11:51 PM

Actually you can scale on export to FBX, the option is at the top of that FBX export dialogue you screenshotted. Just set it to 100.

Even if you had to scale in blender, it shouldn't screw up all your animations if you just scale the root bone...?

Also I don't understand the comment about apply transformations, I have a model here with many modifiers and the "apply modifiers on export" button checkmarked in your screenshot keeps that from being an issue. So confused...

avatar image Pseudocorpus Aug 14 '14 at 12:07 AM

Yes, you can scale on export. I tried that and it made the model bigger... but the bounding box problem did persist. Now I scale it correctly in blender and the export scale value is on 1.00 not 100 ;)

If I just scale the mesh and armature, it doesen't screw up the animations. But the bounding box problem is only solved by "applying" the transformations, which has nothing to do with modifiers btw. ... I don't know exactly what it does... but I think it can be understood as "baking" or reseting all the transformations to the mesh/armature. See this for details: http://wiki.blender.org/index.php/User:Fade/Doc:2.6/Manual/3D_interaction/Transform_Control/Reset_Object_Transformations

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question