x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unpluggin FLY5 Flight Stick Causes Mouse to Freeze.

I am using Window 7 SP1.

After running a new Advanced Vehicle BP example map, resaving it immediately with my custom name, into the same /maps location, and pressing Play sometime later, the vehicle was going revesre-and-left, therefore it had the wheels turned to the right side, only then I noticed it's using botched inputs from the MadCatz / Saitek Cyborg F.L.Y 5 flight stick that was attached by USB, since do have familiarity it's historically not a good idea to disconnect devices when they are being actively used (consoles, etc) I have stopped the live play in the editor and only then disconnected the flight stick, but it didn't help as that locked up the whole editor and the whole operating system in terms of mouse clicks, effectively the whole system was disabled but however it did kept running.

What I was able to do, I was able to use keyboard (which is a microsoft sidewinder x5) to switch between applications but it took some persistance and quite interesting key combinations to make it do, I was able to bring up the welcome screen, but it would still only work with keyboard, to start the task manager, but the taskmanager didn't work properly as it showed no processes running and I couldn't select anything there, after some minutes I just used the keyboard to get to the shutdown/reboot button and that worked, but kinda...

However this is far from a good outcome, if I had some unsaved changes I would have lost them. Obviously I would have lost all unsaved changes from other applications as well.

I was able to at least partially shut it down, that the editor and the applications did shut down tidly I think, (chrome didn't give recovery offer) but the shutdown did not complete fully as Win7 was sitting there displaying "Shutting Down .." for several hours (I fell asleep) ... however this does sometimes happen (but rarely) for other random reasons so it could have been a coincidence.

I have a Mad Catz R.A.T 5 mouse as well.


  • RAT5 USB DRIVER: 7.0.60.6

  • FLY5 HID DRIVER: 7.0.0.41

  • FLY5 USB DRIVER: 7.0.0.41


Installers I used:


  • RAT_5_Mouse_7_0_60_6_x64_Drivers.exe

  • SHA1: DF766D9628C620CA663A7F97DD9F26EDE641008C


  • RAT_5_Mouse_7_0_45_2_x64_Software.exe

  • SHA1: 6B36981E4B82A13ABC1923B2EDF3FF72F02EC74C


  • MadCatz_FLY5_SD7_0_24_0_64Bit_Driver.exe

  • SHA1: ED1B5FB1C954F61EC44A97BD9BD3F3518ABA9676


The Software is unified and is designed to work with device types from MadCatz/Saitek, not just for the mouse.

I have recently updated the drivers for the mouse/flight stick and the software version, however the software version seems to not be working completely as the GUI for the Profile Editor does not work, however the core still works and I'm able to load all the profiles that I had from before, so in essence there really no issue I can use everything as I did before - I don't think the profiler software could have anything to do with this, since it's separate from the drivers, separate installer.

Prior to this recent update, I cleaned up the registery very well from all of the madcatz / saitek stuff, all those entries that were generated throughtout the years.

While obviously I don't need exactly to have this flight stick in UE4, or that I need one right now at all, it would be cool if UE4 supported flight sticks properly in the future, or if it does already, I guess this was either some fluke or it doesn't work with them properly. So the workaround is obvious, don't connect it prior running UE4 Editor.

DXDIAG

YT Video Example 1 YT Video Example 2

Product Version: UE 4.16
Tags:
more ▼

asked Jul 11 '17 at 03:16 PM in Using UE4

avatar image

ZexaronS
1 3 5

avatar image Doug E ♦♦ STAFF Jul 17 '17 at 03:32 PM

Hey ZexaronS-

Just to ensure I understand correctly, you had a flight stick connected to your computer and when you disconnected it with the editor running, you were no longer to interact with any program with your mouse? Are you able to reproduce this behavior? If so, please provide full setup/reproduction steps to help test the behavior on my end. Do you have the same input issue if the flight stick is disconnected when the editor is not running?

avatar image ZexaronS Jul 18 '17 at 11:44 PM

No I don't have the same issue anwhere else, I disconnect and connect regularly while playing DCS World. This was discovered on accident when I didn't unplugged it after non-ue4 use, started the launcher, editor, advanced vehicle template with starter content and PC desktop targeting, did the usual 3 configs I do for every project, like setting use fixed frame rate at 30, show memory and fps info, and use WASD for flying in editor, and just pressed play inside the editor, the vehicle was controlling "it self" and I know immediately it's another device since I know such moments from console games, and then I stopped the live-play, and disconnected, then the editor froze so hard that it froze the whole DesktopWindowManager of the OS or something more core, it wasn't exporer.exe because then task manager would have worked and I could have killed explorer.exe. I'm quite into PCs, software and hardware, so I did a lot of fiddliing in the past and came across all kinds of things but never saw a task manager not display any processes, and this is the first time I experienced such a lockup, I'm not a reset guy, I manage to crawl back up with all kinds of attemtps, I'm stubborn, so I know there's a lot of stuff that can be recovered from, but nothing in my knowledge worked here, I pressed all kinds of keybord combinations, nothing.

I will try to do a step by step recreation as soon as I have more time, right now it's evening, a day or so.

BTW: These drivers are still available on MadCatz website even tho they're bankrupt, but you probably figured that out by now, I was about to add the links but Mega was so slow that day for some reason and I forgot later.

avatar image ZexaronS Jul 18 '17 at 11:54 PM

Also, this may seem as a too niche thing but actually I really can't afford a 300 dollar flight stick right now, I'm not even that good at the game yet to warrant it, but also it's very tricky, even if I would get it later, not a lot of flightsticks come with double throttles, and this FLY5 is I think is quite rare on the affordable range with double throttles and the button amount, it was bought quite a long time aog, but I even repaired it, cleaned out the sensors so it's good for quite some more time. There's really no replacement that I know of, other than a 350$ or more one with double throttles.

Similarly for the mouse, I'm also doing a lot of desktop work and the horizontal secondary scroll wheel has become a big deal for me and a game changer, I can't just replace the mouse so easily to get off the MadCatz drivers if it's their fault.

So this fix might be worth it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question