x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 build not running with LaunchHelper

Hi all,

why does my HTML5 test game run fine when I test-launch it in firefox and chrome from within the editor, but not when I try to run it with the LauncherHelper.exe after packaging it?

I use the 'ThirdPersonExample' Project without any changes, set up for 'Mobile/Tablet' and 'scalable 3D or 2D'

Firefox 54.0.1 (64-bit) Chrome Version 59.0.3071.115 (Official Build) (64-bit)

HeapSizes tried with 4096 and 2032, makes no difference

Below the results I get when trying to run the game with the LauncherHelper.exe

I have got no experience with web based applications and am having trouble understanding the specialized answers that I find when searching for solutions to this problem. Please let me know if further info from my side can help solve my problem. Otherwise, what should I learn first in order to sort this out?

In order to work on this myself some more: The error message says "If this abort() is unexpected, build with -s ASSERTIONS=1 which can give more information." How do I "build with -s ASSERTIONS=1" and what does this actually mean?

Thanks so much!

[1]: /storage/temp/192230-chrome.jp

Product Version: UE 4.16
Tags:
firefox.jpg (193.6 kB)
chrome.jpg (76.8 kB)
more ▼

asked Jul 17 '17 at 10:48 AM in Packaging & Deployment

Constant gravatar image

Constant
10 2 4 7

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Does the browser's page console, or the network tab in browser's devtools show any errors?

For heap size 2032 is the maximum possible that cannot be exceeded.

Does the project work when hosted on a web server? I.e. perhaps it could be a LauncherHelper.exe specific issue.

If none of those work, any chance you'd be able to zip up a small test case to reproduce?

more ▼

answered Jul 17 '17 at 01:25 PM

juj gravatar image

juj
661 11 4 16

(comments are locked)
10|2000 characters needed characters left

Hi,

thank you so much for the quick reply!

It looks like there is additional information in the page console output and maybe under the network tab but I can not read or interpret them. I attached screenshots.

I have not tested the project with an actual web server, also because I don't know how to do that :-( , but I will have someone help me with this on my end later this week.

I'd be more than happy to provide a test case as well, what would that need to include? The complete UE-project or the packaged HTML5?

ChromeConsole ChromeNetwork FirefoxConsole FirefoxNetwork

chromeconsole.jpg (211.8 kB)
chromenetwork.jpg (184.8 kB)
firefoxconsole.jpg (452.5 kB)
firefoxnetwork.jpg (196.9 kB)
more ▼

answered Jul 17 '17 at 01:56 PM

Constant gravatar image

Constant
10 2 4 7

juj gravatar image juj Jul 17 '17 at 02:28 PM

The IndexedDB related errors can be ignored, since it is disabled by a current configuration option on the page. All files seem to load ok, so no problems there. The relevant issue seems to be that something causes the initial platform memory allocator to fail. Some other issue due to that causes the error trace to be quite cryptic. It looks like the platform is attempting to log that failure, and while doing the logging, it is running to another crash.

I'm not sure what might be the connection here that the project does launch ok in the editor, but not with the launch helper. Does the launch helper fail on all projects like that, e.g. even an empty one? Or I wonder if it might be something specific in the project that causes the crash.

Constant gravatar image Constant Jul 17 '17 at 02:44 PM

Ok, I'll try this with an empty project to see if it has got something to do with the content.

and I'll try running the test projects from a real web server.

Thank you for your help with this! It may be a couple of days until I have done those tests, hopefully I'll find you again in case the problem persists. In that case I'll try and put together a small test project and upload it replicating the issue.

Until then...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question