x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ServerTravel, out of date NetDriver ?

Hi, I'm not sure if this is a bug or if I'm doing something wrong but here is my problem:

When I server travel (non-seamless), this log is printed continuously on the client side during the travel:

 LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

Here is the full log (I think I call ServerTravel at line 91): https://pastebin.com/vjZncwzR

I am using SubSystemNull.

Does anyone knows what this log means ? I can't find any information about this on google.

Thanks.

EDIT: I just tried traveling with the console command in a new empty c++ project and got the same thing, here is the log : https://pastebin.com/VRxAxqGa

Product Version: UE 4.16
Tags:
more ▼

asked Jul 19 '17 at 10:31 AM in Using UE4

avatar image

Hidjy
102 1 5 9

avatar image Visnarel Jul 30 '17 at 01:27 AM

I'm seeing this as well

"LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver"

avatar image Kelteseth Aug 26 '17 at 01:13 PM

Any update on this? Same problem here

avatar image Kanibel Sep 06 '17 at 04:11 AM

Getting the same thing here

avatar image Kelteseth Sep 06 '17 at 10:43 AM
avatar image Kanibel Sep 07 '17 at 04:56 AM

Yes I did, seems odd. As it used to work fine!

avatar image Burnrate Sep 28 '17 at 10:09 PM

Any progress with this?

avatar image masmil1988 Oct 19 '17 at 11:03 AM

Does someone solved anyway?

avatar image Rasped Oct 19 '17 at 06:53 PM

I'm having the same problem.

 SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
avatar image Curs0 Nov 09 '17 at 07:36 AM

same here in 4.18, anyone solved it?

avatar image Animaxe Nov 13 '17 at 08:11 PM

I'm also getting this same problem on 4.18.0 on a project that used to work on UE 4.15. Apparently, this error arises because a chunk of code marked with "TODO: START TEMP FIX FOR UE-42508" (World.cpp - line 6419), as far as i could debug it, the netdriver was ok before this, and would be working if the temp fix hadn't been applied. I'm not using steam subsystem, just trying to connect two machines through PIE.

avatar image chiefGui May 04 '18 at 07:58 PM

Still facing this.

avatar image NathanVMP Mar 18 '19 at 12:56 PM

Still experiencing this in 4.21. Couldn't find anything online about how to fix.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

One possible solution, if you are using the Steam online subsystem, is to enable seamless travel and setup whatever code/bps you need to make that work. I found out that steam does not support server travel calls without seamless travel enabled and the error is exactly the same. Another thing to be aware of is that seamless travel currently doesn't work in PIE. I'm not 100% sure, but I saw a support request on the oculus dev site that mentions this same error, so it's possible that the same restriction applies to the oculus online subsystem.

more ▼

answered Nov 09 '17 at 01:58 PM

avatar image

Modeus Games
116 10 7

avatar image Burnrate Nov 09 '17 at 03:38 PM

I believe this is the correct answer. We are still trying to get our stuff working but the basic connections seem to function through steam using seamless.

(comments are locked)
10|2000 characters needed characters left

4.22 still an issue being ignored...

more ▼

answered Apr 14 '19 at 05:00 AM

avatar image

EvoPulseGaming
30 2 4 11

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question