x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Variable Set not working

I'm trying to set a variable, but its value does not change. The two images inside the rectangle show this.

alt text

alt text

Product Version: UE 4.15
Tags:
untitled.png (598.1 kB)
untitled2.png (522.3 kB)
more ▼

asked Jul 20 '17 at 10:14 PM in Bug Reports

avatar image

Dezembro98
13 1 4 7

avatar image Nachtmahr Jul 21 '17 at 01:55 AM

Can you verify by printing to screen?

avatar image Dezembro98 Jul 21 '17 at 05:06 PM

I tested it here and the value that came out was the same as the image above.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I got it sorted out. This code is inside a Custom Event, there is a Cust. Event that called before that which I showed in the images above, I just changed the order they are called (Before, another custom event was called and then that code was rotated, I reversed the order and the code of the above images is called before and The value exits correctly)

This additional Custom event that I said does not have any code that fiddles with the variables of the "CalcularAtributos" Event but it has influenced the code in some way.

I think it's a bug, but I have no idea why.

more ▼

answered Jul 22 '17 at 02:35 PM

avatar image

Dezembro98
13 1 4 7

avatar image Roxas145 Jul 22 '17 at 09:26 PM

@dezembro98 I have found a similar "bug" in 4.16.2 where my variable would not set another variable. Even an entire array became empty after the loop had finished. This had been caused by a very small delay within a for each loop (but it did fire in the loop). maybe you added a delay somewhere before the custom event?

avatar image Dezembro98 Jul 27 '17 at 03:06 PM

I can try this, I'll make a copy of the blueprint and test it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question