x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Local Disk (Z:) appeared after building for android.

In 'This PC' there is a drive Z that has been mounted (I assume by the packaging process) and it is a mounted folder of my project directory's "Intermediate\Android\APK" .The drive Drive contents I also spotted a Y drive at some point but that isn't there anymore.

I cannot find a way of removing it. It doesn't show up in disk manager, 'diskpart' or 'subst'

Why is this there and how can I remove it?

Product Version: UE 4.16
Tags:
zdrive.png (2.7 kB)
zdrive2.png (71.0 kB)
more ▼

asked Jul 21 '17 at 08:50 AM in Packaging & Deployment

avatar image

KnightArchitects
21 3 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, this is created with Subst and it's used to work around windows maximum path length problems with the Android SDK. It should be removed after the packaging is complete, but I just checked my machine and I also have a Y drive still subst'd. We'll look into that.

It is safe to use

subst z: /d

to remove it

more ▼

answered Jul 21 '17 at 09:30 AM

avatar image

JackP STAFF
515 16 6 19

avatar image KnightArchitects Jul 21 '17 at 09:35 AM

Thanks for the quick reply although I said that it doesn't show up in subst!

alt text

zdrive3.png (2.9 kB)
avatar image JackP STAFF Jul 21 '17 at 09:41 AM

Apologies, we recently changed the method we use to create the path and I'm looking at 4.17. alt text

In any case I believe it should be removing the mapping; I've assigned another engineer who knows more about it to comment on that.

subst.jpg (11.6 kB)
avatar image Chris Babcock STAFF Jul 21 '17 at 05:08 PM

The replacement ant.bat removes the drive it used subst on after ant completes. If the batch file is interrupted it will not run the subst [drive letter] /d which can leave the drive mapped, but it should show up if you do a subst like Jack shows above.

Maybe it is a permissions issue; are you running as administrator? Also, which version of Windows? You could try putting the command in a batch file and right clicking on it to run as administrator and see if that works.

avatar image KnightArchitects Jul 24 '17 at 08:35 AM

I just fixed it! The problem was the fact that I was running as administrator. The drive must have been mapped on my user only and not for the whole system. So I just had to not use admin to make it work.

avatar image DEVARSH mavani Mar 24 '19 at 07:48 AM

hey i am also getting same problem what you exactly did to fix it . please can you help me?

avatar image DEVARSH mavani Mar 24 '19 at 07:53 AM

i am also getting same problem can you tell me how to fix it . please help. i tried as above screenshots but i don't know in which directory to go . whether in my project or ue4.20 directory . i am using unreal engine 4.20.

avatar image JackP STAFF Mar 25 '19 at 11:20 AM

Hi DEVARSH, the directory you're in when you enter the SUBST commands is not important. Just open a Windows Command Prompt and enter SUBST and it should show something like

Z:\: => E:\Projects\MyProject\Intermediate\Android\APK

If it shows that, you can remove the drive letter by using the command line

SUBST Z: /d

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question